Font Woes

Discussion in 'OS X El Capitan (10.11)' started by kenwardc, May 22, 2016.

  1. kenwardc macrumors newbie

    Joined:
    Nov 28, 2011
    Location:
    Berkshire, UK
    #1
    Hi Folks

    I recently had to reinstall El Capitan on my working iMac 27" mid 2011 because of various permissions errors that had crept into the OS. I sorted that by simply reinstalling the OS.

    Once I did that, my fonts all stopped working, so I did a "restore fonts" from the Font Book app.

    All standard fonts now back on stream but all my added fonts are not visible, not working and, if I try to reinstall them using any method at all, I get a brief flash on screen and then nothing. Fonts still not visible.

    If I look in ~/library/fonts the fonts I've tried to installed appear there (see attached)

    Can anyone suggest a solution for this issue? I'm desperately needing to get these fonts installed again and would appreciate any help at all.

    Many thanks
    Chris

    FontBook.jpg
    FontBook2.jpg
     
  2. dianeoforegon macrumors 6502a

    dianeoforegon

    Joined:
    Apr 26, 2011
    Location:
    Oregon
    #2
  3. niji macrumors 6502a

    niji

    Joined:
    Feb 9, 2003
    Location:
    tokyo
    #3
    did you drag all your additionally installed font (not the apple system fonts and apple installed fonts) out of the Library Fonts folder, to the desk top, restart, make sure they really have gone from the Fonts folder and them reinstall then through Font book? don't have documents open at the time that use these fonts.
     
  4. MacGizmo macrumors 6502a

    MacGizmo

    Joined:
    Apr 27, 2003
    Location:
    Arizona
    #4
    Kurt's page is pretty darn informative. But your first point is somewhat incorrect. Fonts installed by the user, either by dragging them into Font Book or double-clicking them, are installed in the ~/Library/Fonts folder. The main Library folder is where fonts that get installed by apps get placed—or fonts that you manually install that you want available for all User Accounts.

    There are exceptions to every rule, of course. But for the most part, the User Library folder is the only one you should be putting fonts into.
     
  5. richard2, Jun 5, 2016
    Last edited: Jun 6, 2016

    richard2 macrumors regular

    richard2

    Joined:
    Oct 21, 2010
    Location:
    England, United Kingdom
    #5
    Try resetting the permissions of your home folder and its contents:

    1. Start your Mac in recovery mode.
    2. Choose UtilitiesTerminal from the menubar.
    3. Enter the following:

      resetpassword
    4. Select the volume Macintosh HD.
    5. Choose your user account.
    6. Press Reset.
     
  6. davvanc macrumors member

    Joined:
    Oct 29, 2015
    #6
    Type "resetpassword" (all one word) and in the resulting utility select the hard drive, select your account, and click the Reset button at the bottom of the window where it says "Reset Home Directory Permissions and ACLs."

    To Repair permissions in OS X 10.11
    Use the following command in the Terminal:
    sudo /usr/libexec/repair_packages --repair --standard-pkgs --volume /

    You can also use OnyX to repair permissions, and it might be worth using OnyX's function to clear the font cache.
     

Share This Page