Fonts displaying incorrectly

Discussion in 'macOS' started by jbardy2, Jan 23, 2013.

  1. jbardy2 macrumors newbie

    Joined:
    Jan 22, 2013
    #1
    I have installed new fonts recently, and a few of them are large families with lots of different styles/fonts such as extra light, extra light italic, semi bold, semi bold italic, etc...

    All of these different styles show up as a separate typeface or family though, so it is very difficult to change the style.

    I have downloaded a trial of Fontexplorer X but have no idea how to fix the issue with this program.

    Can anyone advise?

    Here's an example:


    FontA Bold >
    Regular
    FontA Bold Italic >
    Regular
    FontA Italic >
    Regular
    FontA Regular >
    Regular

    Rather than:


    FontA >
    Bold
    Bold Italic
    Italic
    Regular


    Thanks.
     
  2. justperry macrumors 604

    justperry

    Joined:
    Aug 10, 2007
    Location:
    In the core of a black hole.
    #2
    First thing to do is to open fontbook and validate fonts there, it's under the file menu, you have to select all fonts first though.
     
  3. jbardy2, Jan 23, 2013
    Last edited: Jan 23, 2013

    jbardy2 thread starter macrumors newbie

    Joined:
    Jan 22, 2013
    #3
    I did that yesterday, there were 9 errors which are now removed/disabled.


    What's the next step?


    BTW can I just deactivate all but the necessary fonts as opposed to deleting them? I'm trying to start my library fresh because it's very messy and difficult to choose anything through this swamp of typefaces.

    Thanks for the quick reply.
     

Share This Page