Fonts messed up in Snow Leopard

Discussion in 'macOS' started by powerbook911, Dec 3, 2009.

  1. powerbook911 macrumors 68040

    powerbook911

    Joined:
    Mar 15, 2005
    #1
    Hi

    I think my fonts must be messed up in Snow Leopard. Some system things display strange fonts. For example, my user name in upper right hand corner of the screen doesn't look right.

    ALso, the font on the "tabs," in Safari is not correct, and I can compare it to other SL computers.

    How can I fix this? I don't think it's a missing font since other areas those fonts show up fine. Any ideas? Thank you
     
  2. powerbook911 thread starter macrumors 68040

    powerbook911

    Joined:
    Mar 15, 2005
    #2
    I always end up with the problems impossible to solve. I've been working at this all day.

    Should I try reinstalling the OS ?
     
  3. dashcs macrumors regular

    Joined:
    Oct 2, 2009
    #3
  4. powerbook911 thread starter macrumors 68040

    powerbook911

    Joined:
    Mar 15, 2005
    #4
    dash -

    Thanks, I was getting really anxious, so I just popped Snow Leopard disk into computer. I was running 10.6.2, of course, the disk put me back down to 10.6. I don't know if it was really really bad I did this?

    Anyway, it started to happen again when it booted back up from changing to 10.6, it gave me some kind of message. Anyway, I tried answering it a a couple ways and deleted one font, and then restarted.

    It works now! All my fonts are back, in the system preferences, safari and everything. Turns out more were messed up than I even knew.

    I hope it doesn't happen again. I updated back to 10.6.2 and it's still ok.

    Fingers crossed. I wonder if I slow down my machine doing all those OS changes though?
     
  5. ipedro macrumors 68040

    ipedro

    Joined:
    Nov 30, 2004
    Location:
    Toronto, ON
    #5
    My fonts were messed up when I upgraded from Leopard to Snow Leopard. Because system fonts were missing or corrupted, I couldn't authenticate any administrator password prompt. The prompt would appear and then crash. I couldn't do any administrator level actions because of it.

    This happened right when SL came out so when I called AppleCare about the problem, they referred me directly to the Snow Leopard development team. We tried to work out the problem but I ultimately bought a new HDD and installed Snow Leopard on it from scratch, using the original HDD to grab my files.

    I'm not sure the developers figured out the problem but I haven't heard about this happening to anybody else so I guess they did.
     

Share This Page