Fooling With the Activity Monitor..please help

Discussion in 'MacBook' started by Trondragon, Mar 30, 2016.

Tags:
  1. Trondragon, Mar 30, 2016
    Last edited: Mar 31, 2016

    Trondragon macrumors newbie

    Trondragon

    Joined:
    Mar 30, 2016
    #1
    I will claim no level of intelligence above garden tools from now on...I really messed
    up. I read an article about how you can speed up Safari by deleting quicktime extensions
    in Safari, and instead found Quick Look in my activity monitor on my 13 inch Macbook Pro,
    and deleted it. Now, there are no previews for any photos, and it just shows blank icons
    with jpg written, no actual picture. I cannot import photos from my iphone 4s anymore into
    itunes or even my SLR digital camera into iPhoto or Adobe Light Room, keeps saying jpgs
    are unrecognizable format. Anytime i save a photo off the internet I get the spinning
    beach ball of death, my macbook pro slows down and i have to always wait a minute for
    the spinning ball to go away as my macbook saves the picture.

    -forgot to mention on initial posting I deleted the Quick Look system files from finder too-

    I tried to download Quicklook plug in, mainframe, from developer sites, no dice...I can't seem to get back what I deleted in my less than smart move

    Can anyone please let me know what I can do to fix my macbook?


    OS X Yosemite 10.10.2 (14C109)
    MacBook Pro (13-inch, Mid 2009)
    2.26 GHz Intel Core 2 Duo
    8 GB 1067 MHz DDR3
    NVIDIA GeForce 9400M 256 MB

    Thanks!
     
  2. rixard macrumors member

    rixard

    Joined:
    Nov 9, 2012
    Location:
    Sweden
    #2
    Have you tried to restart your computer? You mentioned that you deleted Quick Look via activity monitor - so as I take it you only stopped the process. Reboot and rejoice.
     
  3. duervo macrumors 68000

    duervo

    Joined:
    Feb 5, 2011
    #3
    Restore the deleted data from your Time Machine backup.
     
  4. deeddawg macrumors 604

    Joined:
    Jun 14, 2010
    Location:
    US
    #4
    Not particularly applicable if the OP merely killed the process in Activity monitor.

    @Trondragon -- unless you've done something else that you've not mentioned, simply restarting your computer should take care of things. Sounds like you simply killed the running process rather than deleting any files.
     
  5. Trondragon, Mar 31, 2016
    Last edited: Mar 31, 2016

    Trondragon thread starter macrumors newbie

    Trondragon

    Joined:
    Mar 30, 2016
    #5
    I've restarted many many times since then, it is not a matter of restarting it, I guess i forgot to mention I went into the finder and moved its file to the trash as well. So unless there was a ghost in the shell helping me inside my computer reinstall emptied trash items, restarting would have no effect at all. This happened a few weeks ago, so I have restarted plenty since then, and went onto mac developer websites to attempt to download the quick start mainframe but was not successful, I was hoping some folks on here that had more indepth knowledge may share their suggestions

    You think time machine will restore deleted files i deleted from the finder windows? It is worth a try...
     
  6. deeddawg macrumors 604

    Joined:
    Jun 14, 2010
    Location:
    US
    #6
    That is a rather critical detail to have left out... :rolleyes:

    Yes, that it sort of the point of TimeMachine. I forget whether it backs up system files, others may have more info there.
     
  7. rixard macrumors member

    rixard

    Joined:
    Nov 9, 2012
    Location:
    Sweden
    #7
    If this happened to me I would enter recovery mode and reinstall OSX. Either that or have another look at getting back the necessary frameworks. Google is your friend.
     
  8. PTLove macrumors 6502

    Joined:
    Sep 12, 2014
    #8
    Yeah, that's kind of the MOST critical piece of all of this. The activity monitor stuff doesn't mean anything. That's where you caused the issue.

    Im not sure if TimeMachine backs up System files. Id presume it would, in which case you can simply restore via that.
    Otherwise, im not sure if OSX has a "repair" options for exactly this sort of thing. I know that Windows does.

    As a third (longer shot) option, just try copying over someone elses files. I wouldnt imagine these files are system dependent, so just replacing them outright forcefully may work.

    If ALL of that fails, you have to reinstall the OS.
     
  9. Buerkletucson macrumors 6502

    Buerkletucson

    Joined:
    Sep 12, 2015
    #9
    Do a recovery from Time Machine and you'll be set.....that's what it's for.
    It wipes your HD and recovers EVERYTHING from TM.

    Power up your Mac and hold down the Command and R keys to enter the OSX Recovery Partition. Your Mac should boot to a screen that says OS X Utilities. Select Restore from Time Machine Backup and click Continue.
     
  10. throAU macrumors 601

    throAU

    Joined:
    Feb 13, 2012
    Location:
    Perth, Western Australia
    #10
    Alternatively, if time machine didn't work, you can reinstall OS X.

    Unless you explicitly go into disk utility and wipe the disk, it will reinstall over the top of your existing OS and you will not lose data.
     
  11. IowaLynn macrumors 6502a

    IowaLynn

    Joined:
    Feb 22, 2015
    #11
    ALWAYS have a clone of your system
    Even if just minimal which can be a 100GB partition on another drive, even the one used for TimeMachine.
    http://www.bombich.com

    sending files to Trash can be restored from Trash.
     
  12. Trondragon thread starter macrumors newbie

    Trondragon

    Joined:
    Mar 30, 2016
    #12
    You guys are awesome thanks for the great suggestions, I didn't realize time machine would have system files as well, I don't have the OS disk and trying to torrent that stuff is tricky, was never good at that, but the TM from an earlier back up
    sounds like a plan. Kind of low on funds right now, job searching, otherwise I'd just have gone to a local mac repair shop I know of and have them copy system files over from external HDs with the OS on it they have...I'll try to the TM fix sometime today and update with results Thanks again!
     
  13. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #13
    If Time Machine does not fix your issue, you can easily reinstall OS X, by booting to your recovery system.
    Restart, holding Command-R.
    Choose "Reinstall OS X" from the menu.
     
  14. deeddawg macrumors 604

    Joined:
    Jun 14, 2010
    Location:
    US
    #14
    Your initial post mentioned you're on Yosemite. You can always re-download the OSX install image from the Mac App Store, and there are techniques to create a bootable USB stick with that installer image loaded onto it. I'd really suggest doing that sometime. It's pretty easy.
     
  15. Trondragon thread starter macrumors newbie

    Trondragon

    Joined:
    Mar 30, 2016
    #15
     
  16. Trondragon thread starter macrumors newbie

    Trondragon

    Joined:
    Mar 30, 2016
    #16
    Ok... here is the update....

    I went into time machine, I searched for specific files relating to Quick Look
    and figured out the exact files I had deleted that after deleting caused me
    to be unable to download pictures from my iPhone to iPhoto when connecting
    to my macbook pro via itunes, unable to download photos from my canon rebel
    XTI camera into Adobe Light Room or iPhoto, and with no image previews for
    picture icons, they are as follows:

    quicklook-satellite-general.sb
    quicklook-satellite-legacy.sb
    quicklook-satellite-personal.sb
    quicklook-satellite.sb

    I found them in Time Machine going back to Nov of last year,
    I clicked restore, and it booted me out of Time Machine,
    the files were not restored, tried this a few times, no dice.

    I navigated to Backups.backupdb folder in my external HD
    that TM is connected to, and found these files, as well as
    the QL framework, there were two, one with UI in the title
    the other just Quicklook.framework. I dragged and dropped
    them from my external HD Backups.backupdb's folder in TM
    into my Library-->Quick Look folder.

    I restarted. Nothing same blank icons with the words jpeg written
    instead of small picture icons.

    I continued to google and search on forums

    Some advised when the icons of images
    didn’t show small images as a preview but
    just blank with jpg written on them to delete
    com.apple.finder.plist from the library preference
    plane.

    I navigated to this finder window and well,
    this file wasn’t even there, so i got it
    from TM and put it there, nothing changed,

    I deleted it from there, then all my icons
    went blank without the jpg written just blank
    white boxes, so i put it back now the blank
    white boxes went back to what they were after
    i deleted the quick look satellite files of just
    saying jpg on them but no image preview

    So I repaired disk permissions with disk utility since
    another user on another forum, who although he didn’t
    delete the quicklook files, had the same issue of not
    seeing the image preview in the icons of his picture files
    but blank boxes with jpg written in them like me

    Repaired all the disk permissions, no change nothing

    My mac restarted faster, which is cool, but nothing
    to address the QL issue.

    On this site, http://www.quicklookplugins.com/how-to-install/
    it said:

    "to install QuickLook plugins, you should copy the “*.qlgenerator” file into /Library/QuickLook/ or ~/Library/QuickLook/. Note that “*” in the filename will vary based on exactly which QuickLook item you choose to install.
    If a QuickLook folder is not present, feel free to create one.
    After copying the file into the directory you will need to logout and then back in to your account for it to become active. Alternatively, you can prevent having to logout by running the following command in Terminal:

    qlmanage- r

    This will force OS X to search /Library/QuickLook and ~/Library/QuickLook for plugins and load them accordingly."

    Well this command line doesn't work in Yosemite.

    I tried another terminal command

    defaults write com.apple.finder QLEnableXRayFolders 1

    Restarted

    No change, still cannot see a preview of my pictures
    However, after moving the framework into my QL folder,
    now the icon is in the finder window with the little eye,
    and if i press spacebar i can see a full size image full screen
    but this is useless if you are looking at a finder window
    with a hundred pictures and you just want to see which icon
    is what picture, without having to open EACH ICON! Apologize
    for the caps...i spent hours on this...super frustrated now.

    I did all this to avoid reinstalling the OS because I figured
    the reinstall would take forever, but now thats a doublestandard
    given the amount of time this 'workaround' by dragging and dropping
    individual files from TM back into Library folders was taking, and
    restarting.

    I wanted to find a terminal command to clear the QL cache or something
    and activate QL, but i could not find one for Yosemite.

    Onward through the mainframe fog...

    So I found this page:
    http://apple.stackexchange.com/questions/128825/quicklook-blanks-when-displaying-some-images

    Where a user references a workaround on this page

    http://www.quicklookplugins.com/2009/10/01/animated-gif/

    and answer 15 states this:

    "OSX Yosemite and beyond GIF QuickLook secrets manual
    I’m leaving this because I had such a hard time figuring out how to fix it.
    This plugin works BEAUTIFULLY from OSX 10.5 Leopard to 10.9 Mavericks. If you have these platforms, get it and run the installer. If you have OSX Yosemite (or, predictably, anything beyond it), Apple has added NATIVE Quicklook support for animated GIFs. This plugin BREAKS THIS SUPPORT.
    If you had the plugin prior to upgrading to Yosemite, the upgrade will not remove it and your GIF functionality will not work in QuickLook.
    To UNINSTALL this plugin, go to the /library folder and open the QuickLook folder. This is NOT the MacOS Harddisk/library or System/library folder. It’s a HIDDEN fo
    lder in your own directory. To access it, click the GO menu in the Finder menu (top bar) and press and hold the Option key. Select the “Library” directory that appears there. Inside the Quicklook folder, you’ll see the actual AnimatedGIF_QL.qlgenerator plugin file. DELETE it and you’ll immediately have your native GIF support working again."

    Feeling hopeful,

    I went to this hidden library folder, and the quick look folder had 0 contents
    from this library directory.

    I dragged and dropped the quick look frame work files both regular and UI,
    and the quicklook satellite files i originally had deleted into this folder

    restarted the mac

    Nothing no difference, no icons showed a small picture of
    the jpgs, so I did all this this to try to avoid spending a lot of
    time on it, ironically, but it was down the rabbit hole, so i said
    screw this, I’m just going to reinstall the OS as Delta Mac, ThroAu
    and others suggested.

    I'm excited now, like F everything else, finally, I'll just sit thru
    the lengthy install but after that, everything will be back to normal.

    I restart, Command-R, select reinstall OS, sign in with my apple ID
    and it says 'this application is not available at this time"

    I'm so done for now trying to trouble shoot what i thought would
    be a simple issue to fix. I apologize for the length of this post,
    when I find a solution I want every step logged for others
    who I've seen on other forums with the same issue who are
    still trying to find a solution to QL not working

    Also, if there is some basic thing I am too obtuse to see, please
    feel free to point it out..I'm just overly aggravated now with this
    issue which should not be this challenging to solve.
    Thanks
     
  17. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #17
    I really think it would be much faster just to command-r boot to recovery and reinstall the OS at this point like DeltaMac suggested. That will replace the missing files you deleted and will not remove your personal data files.
     
  18. DeltaMac macrumors 604

    DeltaMac

    Joined:
    Jul 30, 2003
    Location:
    Delaware
    #18
    OPs post #16 was kinda l-o-n-g, but does say he tried the recovery system reinstall, yet (somehow) gets "application not available at this time", which does not seem to be a real result (not from the recovery system, which should just download the system installer files, reinstall, and be done.)
    Anyway
    @Trondragon - If your normal system boots OK, you can also download the Yosemite installer from your App Store.
    (assuming that you have it in the Purchased tab in your App Store :D )
    That will download the installer app, and will automatically launch the OS X installer when the download completes.
    I would suggest that you Quit the installer at that point, and create a bootable flash drive for the installer, using one of several methods that you can search for - or just ask, and someone here will help you out with that, too.
    Then, boot to the installer that you created, and reinstall OSX using that.
    And, that will fix up your issues (and you will have the installer ready to go again, without needing to download the whole thing next time)
     
  19. deeddawg macrumors 604

    Joined:
    Jun 14, 2010
    Location:
    US
    #19
    Agreed, it can be tricky to reinstall OS files on top of the OS you're already running.

    I again highly recommend creating a bootable USB installer for Yosemite.

    Instructions from Apple Support: https://support.apple.com/en-us/HT201372
     
  20. Trondragon thread starter macrumors newbie

    Trondragon

    Joined:
    Mar 30, 2016
    #20
    Again apologies for the length of the last post, I just wanted to be thorough and ideally avoid having you suggest stuff I already tried.

    I do not have the OS in the purchased tabs because I bought this macbook pro off of ebay preloaded with the OS. Other ideas?
     
  21. deeddawg macrumors 604

    Joined:
    Jun 14, 2010
    Location:
    US
    #21
    Got any mac-owning friends nearby that could download Yosemite for you?

    If not how do feel about upgrading to El Capitan?
     
  22. Trondragon, Apr 1, 2016
    Last edited: Apr 1, 2016

    Trondragon thread starter macrumors newbie

    Trondragon

    Joined:
    Mar 30, 2016
    #22
    Also, I thought about restoring the HD from an earlier TM back up, the whole shebang
    but it told me that it would erase what I have now. If per se I did this, would I be able to
    restore the lost data from the last time machine back up i did this morning ?

    And if so, would it remove the system files that the earlier HD back up may restore?
    --- Post Merged, Apr 1, 2016 ---
    --- Post Merged, Apr 1, 2016 ---
    I bought the neighborhood mac shop a 6 pac of beer last time
    i was there for their hard work...maybe they will do me a favor here...
    i will check the next time I have time to swing by the shop
     
  23. throAU macrumors 601

    throAU

    Joined:
    Feb 13, 2012
    Location:
    Perth, Western Australia
    #23
    This

    The further you go with hackery trying to manually replace files that time machine wouldn't restore the more likely you are to cause further damage. OS X reinstalls really are relatively painless and should fix it.

    If you're getting unavailable application errors, try find out which application it is and reinstall from the app store.

    Failing all this - wipe the disk (from within OS X installer run disk utility first), reinstall OS X and restore from TM backup.
     
  24. Trondragon thread starter macrumors newbie

    Trondragon

    Joined:
    Mar 30, 2016
    #24
    As i said I don't have the OS X disk or I'd already have re installed
    It is not in the application store because I bought the mac from ebay
    with the OS already installed, otherwise your suggestion would be
    on point, and I'd have already done it
     
  25. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #25
    How about just do an upgrade install of El Capitan. That should fix it.
     

Share This Page