Football manager 1280x800 display problem

Discussion in 'Mac and PC Games' started by pouttu, Aug 10, 2008.

  1. pouttu macrumors newbie

    Joined:
    Aug 10, 2008
    #1
    Hello, my first post on these forums :)

    One month ago I bought a new macbook and football manager 2008 to have something to play on it.

    The game is working like a charm, but im having problems with the resolution because if I run it fullscreen i have these two black columns on each side of the screen which really bother me, and if i run it in windowed mode some of the window is out of my desktop because the "taskbar" (or whatever the mac version is called :) ) in the top of the screen blocks me moving it all the way up. Also a weird thing is that if i select windowed mode the window is suddenly 1280x800 instead of the 1024x800 of fullscreen >:s

    I have been googling my ass of for the past week and found nothing on any forum about this problem on mac+fm08, hard to believe i'm the only one with this problem...

    Anyway, in windows the solution seems be to put commands like
    -windowed -small_screen or -fullscreen -resolution_1280x800 in the shortcuts properties, i was wondering if in mac os x leopard you could put some similar commands in some startup script somewhere?

    Thought this to be the appropriate place to ask because the sports interactive mac support forums seem quite deserted

    Thanks beforehand
     
  2. lindstrom macrumors member

    Joined:
    Sep 13, 2006
    #2
    I am not sure if you can stretch the window. I have just accepted that now play it in regular windowed mode. The skin I use doesn't show any info at the bottom that is cut off, so I don't miss anything really.

    You could always run FM in windows via Bootcamp/Fusion/Parallels =).
     
  3. pouttu thread starter macrumors newbie

    Joined:
    Aug 10, 2008
    #3
    Thanks a lot, seriously i haven't even thought about changing the skin. Wouldn't have propably come up wih that in million years... :p
     
  4. MacBoobsPro macrumors 603

    MacBoobsPro

    Joined:
    Jan 10, 2006
    #4
    Yeh it doesnt fit well on a MacBook. I usually run it in windowed mode and just about manage to get around.

    FM (especially on a mac) is one of the most buggiest apps out there and always has been. The guys that make it aren't very professional either. Shame its so damn addictive! :D
     
  5. dual macrumors newbie

    Joined:
    May 9, 2007
    Location:
    England
    #5
    Your along the right lines with the command line codes, though that is more windows based.
    Funnily enough though, there are some instructions to get it to be a true, widescreen, rather than windowed mode, hidden away on the sigames website. Its quite simple. Simply download this file, and place it within your football manager folder with the .app. Its only a .txt file btw.

    Heres what you should get

    http://img362.imageshack.us/img362/4295/picture2bd9.jpg
     
  6. pouttu thread starter macrumors newbie

    Joined:
    Aug 10, 2008
    #6
    For some reason the command_line.txt doesn't seem to work for me... maybe i'm doing something wrong but i don't think so, i placed it in /applications/football manager '08 where my .app is, didn't help :(

    After trying that i did some digging up in the sigames support that you mentioned and actually found out how to run the game with command line options:

    "
    The Mac application is a bundle, which is essentially a special kind of folder.

    To run FM with command line options, you need to run the game from the command line (Terminal, in Mac OS X).

    Navigate to the main FM application file, usually by using the following command:

    cd /Applications/Sports Interactive/Football Manager 2007/
    Press return. Then you need to navigate into the actual application bundle:

    cd fm.app/Contents/MacOS/
    Press return again; now run the FM command line application with the command line options you like, e.g:

    ./fm --windowed
    You must include the "./" otherwise the system will display an error.
    "

    from http://www.sigames.com/sibase.php?type=view&id=200

    so after ./fm --fullscreen_widht=1280 --fullscreen_height=800 i got the game to run in fullscreen 1280x800, although the only way to do this is to run it from the command line every time. too bad i didn't get the --small_screen to work with --windowed...

    also after trying out the command line options now every time i select "windowed" ingame, instead of the 1280x800 window it used before it now shows the 1024x762 window (i have no idea why), which makes the windowed mode much more usable :)
     
  7. dual macrumors newbie

    Joined:
    May 9, 2007
    Location:
    England
    #7
  8. aritwik macrumors newbie

    Joined:
    Oct 18, 2006
    #8
    Duals file above works. You only need to remove the "_" from the file name. No need for the long drawn command line process.
     

Share This Page