For anyone who's "Messages" app is broken after upgrade

Discussion in 'OS X Mavericks (10.9)' started by adnbek, Oct 22, 2013.

  1. adnbek macrumors 65816

    adnbek

    Joined:
    Oct 22, 2011
    Location:
    Montreal, Quebec
    #1
    Since GM 1, my Messages app wouldn't work properly and for the life of me I couldn't figure out why. It would start up but no windows would show up. Couldn't see the main setup window or conversation window either. Only window that would appear was a separate "New conversation" window if I chose "new message", but everything else was broken.

    In the Guest account however, Messages worked fine. Then I noticed in Console an error regarding fonts when launching Messages from my user account.

    Anyways, so I had disabled a bunch of fonts in Font Book leaving only the essentials that I wanted. Apparently, Messages needs some non-system essential fonts enabled (helvetic, lucida, emoji, apple gothic and 1 or 2 others) or else it goes wonky. In my case, I had "Apple Gothic" disabled and that's what caused Messages to stop working.

    Just sharing in case anyone else is having trouble with Messages in Mavericks and has some fonts disabled.
     
  2. droach587 macrumors newbie

    Joined:
    Dec 16, 2013
    #2
    Thank you.

    I spent 3 hours trying to figure out why messages wasn't working, and this fully solved my issues.

    Thank you.
     
  3. LV426 macrumors 6502a

    Joined:
    Jan 22, 2013
    #3
    Well spotted. You should definitely report that as a bug to Apple.
     

Share This Page