For Those With Activation Issues (AT&T upgrading from i4)

Discussion in 'iPhone' started by mbsaeger, Oct 14, 2011.

  1. mbsaeger macrumors 6502


    Jun 18, 2009
    After 5 hours, I finally activated my iPhone 4S. What I did:

    First when I got my i4S I tried to activate as normal with NO success. Then I called AT&T and had them put in the phone information and new sim info manually. Then I tried again to activate it with NO success. Note: at this point my old i4 reported No Service and was deactivated.

    **Hours of anger and mean phone calls*

    I finally decided to make my OLD i4 work...I took the sim out of my new i4S and then put it in my my i4 was usable again. Then i finally (for the hell of it) put the sim BACK into my i4S and rebooted. I then activated within 30 seconds.

    See if this works for you.
  2. digitalfx macrumors 6502a


    Jul 18, 2007
    Just got off phone with ATT and my phone is set up with new sim. Just tried your trick and no love. Still won't activate.
  3. rkahl macrumors 65816

    Jul 29, 2010
    I got my iPhone at 4:30pm, no problem activating at all.

Share This Page