For those with black screen after XBMC install

Discussion in 'Apple TV and Home Theater' started by benjaminwood, Jan 22, 2011.

  1. benjaminwood macrumors newbie

    Nov 23, 2010
    This may be elsewhere on the forum, but I couldn't find anybody that had a solution (for me anyway). I ended up figuring it out myself. After jailbreaking with seasonpass and installing XBMC, all I got was a black screen after tethered-booting. I could use the remote and hear the clicking sounds... but no video.

    Here's what fixed it for me. Let me know if this works for you.

    1. SSH into the apple TV from terminal. Example: ssh root@ (Password will be alpine if you haven't already changed it)

    2. Type "ps -ax" and look for in the list. Make note of the number to the left.

    3. Type "kill" and the number to the left that you made note of from step 2. Example: kill 26

    That's it! If you're experiencing the same problem I was, your AppleTV will reload it's GUI and you'll have picture!

    Hope this helps somebody. My apologies if if this is common knowledge and has been discussed elsewhere.

  2. finaluser macrumors newbie

    Jan 22, 2011
    It Works For Me Thank You


    The solution Works for me. Thanks for the post.

    Apple TV 2, 4.1.1
    XMBC (Seas0npass)
  3. jefesupremo macrumors newbie

    Jan 26, 2011
    I joined this forum tonight after encountering this same problem. I found your suggestion just when I was about to give up and put the atv2 back in its nice little box.

    Well, I tried it and it fixed my problem.

  4. benjaminwood thread starter macrumors newbie

    Nov 23, 2010

    Awesome, thanks for the feedback guys. Glad to help!
  5. OptyCT macrumors 6502

    Nov 9, 2008
    I think some of the problems may exist due to some vague instructions on how to boot tethered. I was able to find instructions for this on one site and it has worked flawlessly over multiple reboots. When Seas0nPass asks you to "Connect USB, POWER, then press and hold...", you should first connect the USB. Then, wait for the white power indicator light on the ATV to blink rapidly (around 5-10 seconds). Only after it is blinking rapidly should you plug in the power cord. After the power is hooked up, proceed to hold the MENU and PLAY/PAUSE button for seven seconds and let Seas0nPass do its thing.
  6. khirok macrumors newbie

    Jul 10, 2009
  7. cadeucsb macrumors member

    Jul 5, 2007
    man, this is a problem on the atv2? I am running xbmc 10.0 on my atv1 and was going to upgrade to the atv2 for 1080p and the resolution of this same black screen issue over hdmi (can hear xbmc working, but cant see it). I didnt have the issue over component.

    glad there is a fix, but come on xbmc devs.

Share This Page