Force audio to use internal speakers?

ppc_michael

Guest
Original poster
Apr 26, 2005
1,498
2
Los Angeles, CA
I have a friend with a rather old PowerBook (the kind with the ports in the back). His headphone jack broke off in the plug and it's basically impossible to remove, so the computer is "stuck" playing audio through the headphone jack, even though nothing's attached to it.

Is there a way to force the computer to use the internal speakers instead? Like editing a plist or something?

He's running 10.3.
 

ViViDboarder

macrumors 68040
Jun 25, 2008
3,447
0
USA
I have a similar problem... This thread is quite old -- no solution?
In your sound settings, isn't there an option to chose where to play things? Or does internal speakers get changed to headphones when something is plugged in?

I don't have mine with me to test.
 

GGJstudios

macrumors Westmere
May 16, 2008
44,365
703
fiddle around the with audio settings in system prefs.
The Sound Preferences will not let you select anything other than the current output device. If you have nothing plugged in, the only device on the list is Internal Speakers. If you plug in headphones or speakers, the only device on the list changes to Headphones, and Internal Speakers is no longer an option. When you plug anything into the headphone jack, it overrides and replaces the internal speakers.
 

Xander562

macrumors 68000
Apr 2, 2006
1,628
0
Either keep trying to remove it, look for a third party program, or get an external DAC (Digital-analog-converter) You can pic some up for <$100 for sure.