Force Delete stubborn EFI Patition

Discussion in 'Mac Basics and Help' started by X4rg0n, Oct 12, 2015.

  1. X4rg0n macrumors newbie

    Joined:
    Oct 12, 2015
    #1
    Hi there,

    I need some help to delete a stubborn EFI. But first some informations.
    I use a MacBookAir6,2 with the newest OS X 10.11.1 and I am trying for
    days now to delete an EFI Partition on an SD Card. I want to use it in my
    Raspberry Pi with OSMC. However the OSMC installer don't see the SD Card
    and I think it is because of the EFI Partition.
    So I want to delete it. There are no files to backup.
    Unfortunately diskutil doesn't help at all. Delete don't change anything on the
    SD Card. And all over that the command:
    defaults write com.apple.DiskUtility DUDebugMenuEnabled
    don't show the Debug Mode in diskutil.
    So I googled my issue and found the gpt terminal command. Also it doesn't help.
    The command works fine at first.
    No errors. However when I use diskutil list the partition is not deleted.

    I am helpless. Do you have some ideas I could try to delete this stubborn EFI partition?

    Thanks for you help.

    Greets Xargon
     
  2. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #2
    You'll need to repartition the card as MBR type formatting. This is apparently only possible through the command line now, unless I'm missing something.
    so in Terminal you need to enter the following to find your card:
    Code:
    diskutil list
    Then, you should see a number of disks listed in that output. You should be able to see the card you have from there, and it'll show as something like the following:
    Code:
    /dev/disk11 (internal, physical):
      #:                       TYPE NAME                    SIZE       IDENTIFIER
      0:     FDisk_partition_scheme                        *63.9 GB    disk11
      1:               Windows_NTFS                         63.8 GB    disk11s1
    
    So now we know that our card is identified as /dev/disk11. Your card may have a different identifier. Note what that is, and make sure that you have it correct, as you can lose data if you get this wrong. This is important in the following step. This will actually format and repartition the card so any data on it will be removed. Enter the following in Terminal:
    Code:
    diskutil partitionDisk /dev/disk11 MBR FAT32 UNTITLED 0b
    This tells diskutil to partition the disk at /dev/disk11 as Master Boot Record (Windows/MS-DOS default), in FAT32 format, named "UNTITLED", and the 0b part tells diskutil to use all available space. Note that any name you use has to be FAT32 legal, including all capital letters.
    Once you've done this the RPi installer should work fine to format the card as it needs.
     
  3. X4rg0n thread starter macrumors newbie

    Joined:
    Oct 12, 2015
    #3

    Thanks for you answer. Unfortunately it didn't work. I want to repartition disk2.
    Bildschirmfoto 2015-10-12 um 16.19.37.png
    After the line "Finished partitioning on disk2" it shows disk2. However it looks like before.
    How can that be?

    Edit: The Raspberry Pi wants a mircoSD. However my MBA just has a normal SD Slot. So I use an adapter. This adapter has a lock slider. But it is set to unlocked. Could this make problems?
     
  4. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #4
    It's not actually partitioning your card. Is the write protect switch set?
    Edit: also, it's not necessary to use sudo for this.
     
  5. X4rg0n thread starter macrumors newbie

    Joined:
    Oct 12, 2015
    #5
    No it isn't.
     
  6. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #6
    Erase the card first using the GUI Disk Utility and see what happens.
    Edit: I just found the partitioning options hidden in the Erase command in Disk Utility, so this should make the command line unnecessary.
     
  7. X4rg0n thread starter macrumors newbie

    Joined:
    Oct 12, 2015
    #7
    Do you mean it like this?
    Bildschirmfoto 2015-10-12 um 18.31.17.png
    The Problem is it fails with the error " clusters too few clusters for FAT32, need ..." Bildschirmfoto 2015-10-12 um 18.34.49.png And when I try to format exFAT it says the process was successful, however with the same result then the command line process. The partitions keep unchanged.
    Bildschirmfoto 2015-10-12 um 18.38.13.png
    Even the same when I just try to delete the OSMC partition and rename it to UNTITLED. After the process nothing changed.

    An other problem is I can't activate the debug mode in diskutil. So it does't show the hidden EFI partition.
     
  8. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #8
    How about using
    Code:
    diskutil partitionDisk /dev/disk11 MBR MS-DOS UNTITLED 0b
    instead of FAT32. (obviously, set your own disk identifier in there.)
     
  9. X4rg0n thread starter macrumors newbie

    Joined:
    Oct 12, 2015
    #9
    Same error like with diskUtil GUI. Bildschirmfoto 2015-10-12 um 19.30.58.png
     
  10. chrfr macrumors 603

    Joined:
    Jul 11, 2009
    #10
    There's also the FAT16 option. It may also be just that your card is failing. For what a new 8GB SD card costs, it may not be worth trying to keep using it.
     

Share This Page