Force iPhone to copy contacts To outlook

Discussion in 'iPhone Tips, Help and Troubleshooting' started by JoganJani, Nov 21, 2007.

Thread Status:
Not open for further replies.
  1. JoganJani macrumors member

    Joined:
    Oct 23, 2007
    #1
    Is there a way to force synch to copy all contacts from iPhone to Outlook? I know there is a checkbox for copying all from Outlook to iPhone. Somehow I've searched all threads and do not find an answer to make synch update my outlook contact. It did copy all contacts at fist synch from outlook to iPhone but nothing is updated back in outlook from iPhone.

    Facts:
    iPhone 1.1.2
    Otlook 2003 on XP with SP2
     
  2. rayward macrumors 65816

    Joined:
    Mar 13, 2007
    Location:
    Houston, TX
    #2
    The iTunes add-in within Outlook may have been disabled. This happened to me a lot at first, and it's one of those annoying intermittent bugs. What happens is that Outlook crashes because of the iTunes add-in, and will only re-open if the add-in is disabled. This comes up in one of those Windows dialog boxes that you just click "OK" to get rid of without actually reading.

    Outlook will run fine from then on, but there'll be no sync to iTunes. Typically, if you re-enable the add-in, Outlook will crash immediately upon the required restart, and then disable the add-in again.

    Look to see if the add-in is disabled (it's under the Help menu). If it's not, then you have another problem with which I cannot help. If it is...

    The way I fixed this is as follows:
    1) Re-enable the iTunes add-in.
    2) Shut-down Outlook, but before re-starting it, reinstall it from your Office CD.

    This should allow Outlook to open with the add-in enabled. Your sync will work and it should update all the changes you've made on either you PC or iPhone.

    WARNING: The add-in may well cause another crash of Outlook at some random point in the future. It did for me on two or three occasions. The third reinstall seems to be holding...at least for the last few months...so MS may have fixed the issue. If it crashes tonight when I get home, I know who to blame!!!
     
  3. JoganJani thread starter macrumors member

    Joined:
    Oct 23, 2007
    #3
    Thanks for the reply. But my add in is enabled. I've also reset synch history several times in iTunes to no luck.
     
  4. wsellers macrumors newbie

    Joined:
    Jul 2, 2007
    Location:
    Baton Rouge, Louisiana
    #4
    This worked for me.

    Greetings,

    After spending 2+ hours on the phone with Apple technical support, here is what I found worked.

    http://discussions.apple.com/thread.jspa?messageID=6412482&#6412482

    Please see me post here in clear text: <let me know if this helps you at all>
    -----
    ATTENTION FELLOW IPHONE USERS / APPLE

    I was having the EXACT same problem as the person who originally created this post... Downgrading to iTunes 7.4.3.1 absolutely fixed my Outlook > iTunes > iPhone sync issue.

    FYI - This issue started right after my users upgraded to iPhone firmware 1.1.3 and iTunes 7.6. There may be some issue with the latest version/update of iTunes.

    <Just a CYA, backup all the files/directories that are to be deleted here. -- Use this info. at your own risk.... However, it worked great for me.>

    Here is what I did:

    #1) Under Windows Add remove software, completely remove: iTunes, Apple Mobile Device Support, & Apple Software Update. - DO NOT REMOVE ANY BOOT CAMP SOFTWARE.

    #2) Reboot PC (or Mac running Boot Camp - running Windows)

    #3) Under "C:\Documents and Settings\<user account>\Application Data\Apple Computer", remove any reference to iTunes/Quicktime.

    #4) Under "C:\Documents and Settings\<user account>\Local Settings\Apple Computer", remove any reference to iTunes/Quicktime.

    #5) Under "C:\Documents and Settings\<user account>\My Documents\My Music\iTunes ", rename: "iTunes Library.itl" to "iTunes Library.old"

    #6) Under "C:\Documents and Settings\<user account>\My Documents\My Music\iTunes ", rename: "iTunes Music Library.xml" to "iTunes Music Library.old"

    #7) Download iTunes 7.4.3.1 from: http://www.apple.com/support/downloads/itunes743forwindows.html

    #8) Normally install iTunes 7.4.3.1.

    #9) Once installed, Connect iPhone. GO under the "Info" tab under the iPhone device. Make sure that you have the setting to overwrite the Contacts and Calendars on the iPhone, under the advanced settings area. (remember, you will be overwriting any contacts/calendars that are NOT synced with the computer)

    When you connect your iPhone you will need to totally re sync your Outlook Contacts and Calendars - FROM Outlook TO iPhone (overwrite). Also, you will need to rebuild/re index your iTunes library music.

    This worked fine for me in my particular environment; however, if ANYONE has a quicker/easier way to resolve---possibly without downgrading to iTunes 7.4.3.1, LET ME KNOW.

    You might want to do setups 1 - 6, and just try reinstalling the latest iTunes. If this works for someone, please post.

    Thanks
    Will
     
  5. luckygyrl83 macrumors 6502

    Joined:
    Jun 23, 2008
    Location:
    Fullerton, CA
    #5
    This worked for me. I just had to connect the phone. Go to the Info tab, and make that lil change. THANK YOU SO MUCH!!!!
     
Thread Status:
Not open for further replies.

Share This Page