Force OSX to use AirPort while cable is plugged in Ethernet port?

Discussion in 'macOS' started by SDAVE, Jun 30, 2007.

  1. SDAVE macrumors 68040

    SDAVE

    Joined:
    Jun 16, 2007
    Location:
    Nowhere
    #1
    Hey guys, is there a way to force OSX to use the AirPort WiFi connection for the internet? Because everytime I try to directly connect to another computer and choose "Manual" and enter my router/IP, it won't let me get online, even though AirPort has found a connection. Once I use the "DHCP" (Automatic) connection, it goes online? But I want to use a custom IP on my network and have access to the net!

    Thanks
     
  2. SDAVE thread starter macrumors 68040

    SDAVE

    Joined:
    Jun 16, 2007
    Location:
    Nowhere
    #2
    I know this thread might not make sense...but basically what I want to do is use one of my Mac Pro gigabit ethernet ports to directly connect to another PC via a crossover CAT6 cable. If I enter the IP manually, my internet connection is lost even thought AirPort is still online. Once I change manual mode in the Ethernet port 1 to "DHCP" the internet comes back and I can still transfer files to the other PC...but obviously DHCP is not what I want to use, but a manual setting.
     
  3. basicfiend macrumors member

    Joined:
    Jun 13, 2007
    #3
    You should be able to override all the settings for each network interface separately using ifconfig in the terminal. If you type ifconfig, I'm assuming you'll see three things listed: en0, en1, en2. You'll have to figure out which interface corresponds to the card you want and manually set the IP.

    Here's a good link for ifconfig basics: http://linux-ip.net/html/basic-changing.html
     
  4. SDAVE thread starter macrumors 68040

    SDAVE

    Joined:
    Jun 16, 2007
    Location:
    Nowhere
    #4
    On the windows side, it works fine...but in OSX, I can't put in a manual IP for the Ethernet connection without losing the internet (connected via AirPort Extreme).
     
  5. matthew24 macrumors 6502

    matthew24

    Joined:
    May 30, 2002
    Location:
    Netherlands
    #5
    Probably you will need to add a location. (Network in system pref), by selecting a location you can force the system to use certain settings,
     
  6. y0zza macrumors regular

    Joined:
    Mar 10, 2005
    #6
    This is easily done.

    Go to System Preferences, Network, "Show: Network Port Configurations".

    You can drag the order in which connections are used there. So in your case, you'll want Airport at the top of the list.
     
  7. SDAVE thread starter macrumors 68040

    SDAVE

    Joined:
    Jun 16, 2007
    Location:
    Nowhere
    #7
    Thanks for the info guys...did the above but did not help! Everytime I put Airport on top, my ethernet connection becomes inactive and I can't see the files on either computers. I do gain internet connection when I do this, though.

    Once I move the ethernet connection up on top, I can access the network...but I can't get onlien! Tried everything, and I'm stumped.

    The only way both work is if I use DHCP, but I dislike it because it takes time o find the IP etc.

    Funny thing is, Windows has no such problem. I've networked Windows machines the same way, and I can get online and get files through the network (via Manual IP/Router adresses) without a hitch.

    So please any geniuses out there! THANKS!
     
  8. Celeron macrumors 6502a

    Joined:
    Mar 11, 2004
    #8
    Are you configuring a default gateway (Router setting in network prefs) when you manually configure the IP? If so, you shouldn't, because both machines are directly connected. OSX should use only the interface with a default gateway.
     
  9. basicfiend macrumors member

    Joined:
    Jun 13, 2007
    #9
    I don't have two ethernet cards, so no idea if this will work, but:

    OS X does allow you to share your internet connection. I use this on my laptop where I plug into the switch and use my laptop as a wireless access point.

    I'm thinking you might be able to "share" your internet connection to your windows computer over your second ethernet port.

    The internet sharing options are in System Pref -> Sharing -> Internet Sharing. You have to select which interface is connected to the internet and which interface you want to share the internet on.
     
  10. kg9ov macrumors member

    Joined:
    Feb 12, 2005
    Location:
    In front of a computer...
    #10
    In addition to the default gateway / router setting mentioned above (you don't need a default gateway on the wired port that is just a crossover to another machine), you should also make sure the two network connections are on different IP subnets. For example, if the dhcp subnet (Airport) is 192.168.0.x, then make the manual (wired) subnet something like 192.168.1.x.

    -Tony
     
  11. SDAVE thread starter macrumors 68040

    SDAVE

    Joined:
    Jun 16, 2007
    Location:
    Nowhere
    #11
    You guys are GENIUSES! :D

    It worked great!

    Thanks to all!

    Hope this thread helps someone else in the future.
     
  12. mooncaine macrumors regular

    Joined:
    Dec 19, 2004
    #12
    SDAVE, it'd help future readers best if you take a moment to make clear what it was that actually helped.
     
  13. SDAVE thread starter macrumors 68040

    SDAVE

    Joined:
    Jun 16, 2007
    Location:
    Nowhere
    #13
    Keeping the subnets different for both the wireless and the lan helped.

    For example, lets say the Wireless is on 192.168.1.102, you need to keep the LAN on 192.168.2.110 for example. I also removed the "router" (aka Gateway) and left it blank for both computers (Mac and PC) and all is well. Subnet masks were 255.255.255.0 for both computers.
     

Share This Page