force RBG fix doesn't work on my Mac Mini 2012

Discussion in 'Mac mini' started by Mac Tyson, Sep 27, 2017.

  1. Mac Tyson macrumors regular

    Mac Tyson

    Joined:
    Jul 1, 2010
    #1
    I've been searching for a fix to Mac Mini's blurry HDMI issue. Saw a link to a script and disable SIP and copy to an overrides folder. That fix didn't work and it limited my resolution to lower.

    I have a gaming monitor, Acer Predator XB271HU, it's a 2560x1440 IPS with 165hz refresh rate. It only has 2 inputs, HDMI and DisplayPort.

    My 2013 MacBook Pro has no issues going HDMI to HDMI. Texts and pictures are clear compared to this Mac Mini.

    I used to have this Mac Mini connected to an older monitor, 24" TN panel with 1080p max resolution support. I connected it via DVI-D and didn't experience issues with blurry texts. Now that I have a monitor, a better one at that, with no DVI, it seems my Mac Mini experience has downgraded.

    Anything else to try? I've tried SwitchResX and bumped up the resolution to match my monitor (2560x1440p) but the image is still blurry.

    I'm looking to sell this Mac Mini if anyone is interested. PM me.
     
  2. mbosse macrumors 6502

    Joined:
    Apr 29, 2015
    Location:
    Vienna, Austria
    #2
    The HDMI Port on the 2012 Mac Mini supports 1920x1200 on an HDMI display. For larger, such as your 2560x1440 screen, you need a Thunderbolt or Mini DisplayPort connector to either VGA or DisplayPort. Lenovo makes a good cable for this, #0B58411.

    Best,
    Magnus
     
  3. Mac Tyson thread starter macrumors regular

    Mac Tyson

    Joined:
    Jul 1, 2010
    #3
    This monitor only has 2 inputs. HDMI and Displayport. I don’t intend on switching display ports with my gaming rig. I looked at a displayport switch but it’s too expensive.

    I also tried a combo of different adapters. I did a miniDP to DVI adapter on one end to a DVI to HDMI on the other end. Still blurry text.

    The force RBG script is hit or miss too. It looks like it doesn’t work with High Sierra for some.
     
  4. Fishrrman macrumors P6

    Fishrrman

    Joined:
    Feb 20, 2009
    #4
    "That fix didn't work"

    I suggest you try it again.
    First DELETE any existing override folders.

    When I was working on this, took me a couple of tries to get it right.
    Where the "override folder" goes also depends on which version of the OS that you're using.
     
  5. Mac Tyson, Sep 29, 2017
    Last edited: Sep 29, 2017

    Mac Tyson thread starter macrumors regular

    Mac Tyson

    Joined:
    Jul 1, 2010
    #5
    Was it with High Sierra?

    There's other folks not getting this to work. Look at posts from this week and they mention High Sierra.

    http://www.mathewinkson.com/2013/03...ix-the-picture-quality-of-an-external-monitor

    edit* - I'll retry after deleting all override folders. Does this require SIP to be disabled?
     

Share This Page

4 September 27, 2017