Force Spotlight Index a Time Capsule Drive--- HOW??!?

Discussion in 'Mac Basics and Help' started by zumajoe, Jan 28, 2010.

  1. zumajoe macrumors member

    Joined:
    Aug 8, 2008
    #1
    I would simply like to use cmd+spacebar to be able to search files that are located on my Time Capsule.

    -currently wired via ethernet cable

    -not using Time Machine Backup at the moment, i'm only using my TC as a 'wireless drive'.

    -It will search SOME items on the TC, but very limited results.... very strange.

    -tried all the " sudo mdutil -E" on terminal stuff. I just get this as a result with no index being rebuilt: /Volumes/Data:
    Indexing enabled.


    -searched hours on this and can't figure it out-- most people are trying to disable search, I want to ENABLE.


    Anyone got a clue?
     
  2. Velin macrumors 65816

    Velin

    Joined:
    Jul 23, 2008
    Location:
    Hearst Castle
    #2
    Are you using snow leopard? SL fixed a number of spotlight indexing issues.

    Do your time capsule files have the permissions set correctly? If you have locked folders, this may explain the behaviour you are witnessing.

    Finally, did you try the simplest method? That is, System Preferences > Spotlight > Privacy. Drag your Time Capsule to the privacy tab, then remove it, which should generate a fresh index.


    PS Time Capsule as a remote drive is one of the worst options. The Time Capsule has absurdly long spin up times and lots of spin down. It does this to preserve the drive and ensure longevity -- it's designed that way. We tried to use a TC as a remote drive and almost threw it away, until we did research on the specs for its I/O, etc. But this is why the TC read/writes take so long. TC simply is not good for anything except long-term, or rarely used, backup.
     
  3. zumajoe thread starter macrumors member

    Joined:
    Aug 8, 2008
    #3
    Yeah i'm running SL, latest updates etc.


    Firmware is latest on the TC, and it is also the latest model.


    I've tried the simple method of dragging the TC onto privacy settings, and then deleting it.

    However one thing that is peculiar, is that I cannot actually drag the entire "drive" onto the settings,not even the "Data" folder....it has to only be folders within "Data" that I can drag into Privacy.
     

Share This Page