Force ssh key passphrase

Discussion in 'Mac Basics and Help' started by ben322, Oct 29, 2016.

  1. ben322 macrumors newbie

    Joined:
    Oct 29, 2016
    #1
    Firstly i know that this has been talked about before but none of the solutions that worked that time are working now.

    So i have an ssh key that i use to log into servers and it is encrypted with a passphrase, when i first used the ssh key on my mac it asked for the passphrase, so i entered it, but now it dosent need the passphrase anymore.


    when i run: ssh-add -l
    it gives: The agent has no identities.

    I can also unset the environment variable that allows the ssh process to connect to ssh-add
    : unset SSH_AUTH_SOCK
    and still log in fine.

    this shows that this is not ssh-add and probably the macos keychain that is storing either the decrypted rsa key or the passphrase for the key.

    When i then look through the keychain i cannot see anything that would instantly show up as either the private key or the passphrase.



    If there is anything you think i should try let me know.

    Thanks for any help, Ben
     
  2. satcomer macrumors 603

    satcomer

    Joined:
    Feb 19, 2008
    Location:
    The Finger Lakes Region
  3. ben322 thread starter macrumors newbie

    Joined:
    Oct 29, 2016
    #3
    I did not do anything deliberate to save the password, if it had a checkbox i would have left it unticked as i didn't want it to save the passphrase, as far as i remember.
     

Share This Page