Force wifi calling when on home wifi network?

Discussion in 'iPhone' started by StuMcBill, May 9, 2016.

  1. StuMcBill macrumors 6502a

    Joined:
    Jul 11, 2011
    Location:
    Aberdeen, Scotland
    #1
    I get terrible mobile signal at home, and have WiFi Calling enabled, however, it doesn't always connect to WiFi calling even when I have terrible signal.

    Is there anyway I can force the iPhone to use WiFi Calling when connected to my home network, regardless of cellular network status?

    Cheers
    Stewart
     
  2. I7guy macrumors P6

    I7guy

    Joined:
    Nov 30, 2013
    Location:
    Gotta be in it to win it
    #2
    Turn on airplane mode and wifi, will give you what you want.
     
  3. brewmonkey macrumors regular

    Joined:
    Feb 17, 2016
    #3
    Interesting. Does this work well and reliably? Any caveats/tips/tricks with it that you know of? I currently have Republic Wireless and while I enjoy the wifi calling, I don't enjoy being stuck on Android. If this could be an alternative, that would be fantastic.
     
  4. Chatter macrumors 6502a

    Joined:
    Jun 10, 2013
    Location:
    Uphill from Downtown
    #4
    You have an iPhone and I am surprised as mine always connects to wifi calling if its on. Even in a good signal area. So maybe turning on airplane and wifi is what you need to do.
    --- Post Merged, May 9, 2016 ---
    Not sure if I am answering your question but I used wifi calling on the iPhone exclusively for 2 years (zero signal at home) and never had as problem. But I also got the wifi router from TMobile that prioritizes the calls. I did not need to play with airplane mode at all. Not sure if that had any impact but overall, I had no issues on my iphone.
     
  5. I7guy macrumors P6

    I7guy

    Joined:
    Nov 30, 2013
    Location:
    Gotta be in it to win it
    #5
    It seems to work on my Verizon 6s doing just that.
     
  6. brewmonkey macrumors regular

    Joined:
    Feb 17, 2016
    #6
    Thank you very much @Chatter and @I7guy . Very interesting info...and a new potential option has unfolded for me. Thanks again.
     
  7. StuMcBill thread starter macrumors 6502a

    Joined:
    Jul 11, 2011
    Location:
    Aberdeen, Scotland
  8. AutoUnion39 macrumors 601

    AutoUnion39

    Joined:
    Jun 21, 2010
  9. lordofthereef macrumors G5

    lordofthereef

    Joined:
    Nov 29, 2011
    Location:
    Boston, MA
    #9
    Who is your carrier? This may be a carrier issue. My phone is on wifi calling 100% of the time it's on a wifi connection. Signal strength doesn't matter. We are with T-Mobile.
    --- Post Merged, May 9, 2016 ---
    Does this router actually do something differently than any other router? I ask because T-Mobile offered to send me a cell spot, which they ended up doing, but it's effectively just another N router. I thought I would be getting something that strengthens indoor LTE signal, but that's not what I got. I guess I'm just wondering if there is any point keeping the hardware or not when wifi calling is and has always been working perfectly fine with a router not affiliated with T-Mobile in any way.
     
  10. JT2002TJ macrumors 6502a

    Joined:
    Nov 7, 2013
    #10
    T-Mobile implemented Wifi calling differently than AT&T. AT&T tries to connect to cellular as much as possible, and will fail to wifi calling, while T-Mobile is the reverse (this is my understanding). I have NO idea why AT&T when this route, it is just silly.
     
  11. AutoUnion39 macrumors 601

    AutoUnion39

    Joined:
    Jun 21, 2010
    #11
    Because AT&T (and Verizon) aren't using WiFi Calling as an excuse to spend less on their networks. Without WiFi calling, most T-Mobile users would have a terrible user experience. AT&T/Verizon users? Well, we haven't had it for years because they actually invest $$$ into their networks.
     
  12. JT2002TJ macrumors 6502a

    Joined:
    Nov 7, 2013
    #12
    Except, in the NY area AT&T sucks... I go in and out of wifi calling a ton of places.

    It doesn't hurt to favor wifi these days, everywhere I get on wifi I have LTE speeds. I would like an on and off switch for wifi calling And a favor cellular switch. Best of both worlds.
     
  13. AutoUnion39 macrumors 601

    AutoUnion39

    Joined:
    Jun 21, 2010
    #13
    Hardly. I'm in NY often. Their network is ranked #2 in NYC, above the beloved Uncarrier (and Sprint)
     
  14. JT2002TJ macrumors 6502a

    Joined:
    Nov 7, 2013
    #14
    I live and work in NY... trust me, AT&T has major issues with signal. Yes they are better than sprint and T-mobile, but none are close to Verizon. I won't make the move to Verizon because I would prefer being able to swap SIMs.

    I work in the financial district. Our office was on 14 Wall Street (across from the stock exchange), the only way I had a signal was if I was hugging a window. Thankfully our new office (on Water st) as a good AT&T signal.

    I live in Long Island, everyone I know has some type of signal issue with AT&T (even if it is small)...

    I seem to always have a signal outside, but inside buildings, it is a different story.
     
  15. Chatter macrumors 6502a

    Joined:
    Jun 10, 2013
    Location:
    Uphill from Downtown
    #15
    So the way I understand it, it prioritizes the phone and calling features and directs more bandwidth to them versus other wifi devices. It does not amplify the tower signal though they supposedly have a microcell device for that. Again, this is my limited knowledge on this so I may not up to date on their newer harware.
    --- Post Merged, May 9, 2016 ---
    I would agree with this but from a NNJ perspective. TMo rocks for me everywhere in NYC and NNJ. ATT was so bad my brother gave it up...and then moved to Sprint to save money. So my bro may not be the brightest but ATT would stutter while my TMO was flying. Now as you say, inside buildings, I need wifi.
     
  16. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #16
    Yep, what he said above.
    When I was on AT&T I'd have 1 bar of signal and still wouldn't switch to wifi calling even when I was in the basement next to my wireless router.
    On T Mobile now as soon as I connect to any wifi it automatically switched to wifi calling and stays there.
    Way better than the way AT&T had it implemented.

    That's a poor bs excuse like verizon has been saying for years we dont need wifi calling. We dont need the iphone, we dont need talk and use data at the same time and its the network "can you hear me now" gimmicks.
    I dont want to be with 1 bar signal and have to switch my phone to airplane mode in order to stay on wifi calling and keep solid conversations without breaking in and out. With AT&T it would do that unless I switched it manually to airplane mode and wifi on.
    That's nonsense.
     
  17. westcliffecolorado macrumors newbie

    westcliffecolorado

    Joined:
    Jul 24, 2016
    Location:
    Westcliffe, Colorado
    #17
    This doesn't work for me, for some reason.

    When I turn on Airplane Mode, "Phone" is grayed out and I cannot go in and turn on WiFi.

    iPhone 6SPlus on AT&T
     
  18. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #18
    It works for everyone else.
    You're not doing it right.
    You don't go in to phone.
    You go to settings, wifi and turn it to on.
     
  19. BigMcGuire Contributor

    BigMcGuire

    Joined:
    Jan 10, 2012
    Location:
    California
    #19
    Yes, phone is grayed out for me too but that's normal. I usually use the bottom drawer (swipe up from the very bottom of your phone) -- turn on Airplane Mode. Then I turn on WiFi. And in about 10 seconds I get my VZW W-Fi symbol.

    [​IMG]

    [​IMG]

    Phone is still grayed out in the settings but I can make/receive phone calls and SMS/MMS through iMessage.

    I get 1-2 bars at my house (where I am now) so WiFi calling was a Godsend for me. I use it all the time. Sometimes, because I like it so much, I do Airplane Mode + WiFi calling at work where I have max reception.

    Sometimes it can take awhile for WiFi calling to turn on - make sure WiFi is strong enough too (2 rooms away for me - shows max reception).
     
  20. westcliffecolorado macrumors newbie

    westcliffecolorado

    Joined:
    Jul 24, 2016
    Location:
    Westcliffe, Colorado
    #20
    --- Post Merged, Jul 24, 2016 ---
    Thanks for your help McGuire. That did it. I was going into settings and then could not get to WiFi to turn it on. It is working fine now.
     
  21. ddd22 macrumors newbie

    Joined:
    Apr 15, 2017
    #21
    --- Post Merged, Apr 15, 2017 ---
    Simply Brilliant! On Android here, but with att giving preference to even a very weak cellular connect over Wifi, I couldn't figure out how to completely turn off my cellular connects...airplane mode!...of course!!. An elegant and parsimonious solution. It works....rock solid wifi calling at last! Thank you, thank you, thank you. I set up this account just to thank you and acknowledge a great solution.
     
  22. Bhs1975 macrumors 6502

    Joined:
    Oct 30, 2012
    #22
    My iPhone 7 plus on att will kick in when it's down to 2 dots and not cut off until it's back up to 4 which I think is a great implementation. Will tmobile's kick in even on a weak wifi signal?
     
  23. Applejuiced macrumors Westmere

    Applejuiced

    Joined:
    Apr 16, 2008
    Location:
    At the iPhone hacks section.
    #23
    I think Tmobiles implementation is way better.
    It will stay connected to wifi calling while on wifi.
    It wont connect and disconnect constantly as signal fluctuates.
     
  24. ddd22 macrumors newbie

    Joined:
    Apr 15, 2017
    #24
    --- Post Merged, Apr 17, 2017 ---
    from what i have been able to read across multiple forums is that ATT is setup to prioitize cellular over wifi. tmobile the opposite, favoring wifi calling over cell tower call. with att, here in northern central california, where att service should be an embarrassment to the company, even one weak bar will kick me off the wifi calling unless i turn on that blessed airplance mode.
     
  25. JT2002TJ macrumors 6502a

    Joined:
    Nov 7, 2013
    #25
    This is how mine acts too... Did it with my 6+, and still does it with my 7+. It even acted this way when it first started with AT&T while only on Beta (I did the Beta).
     

Share This Page