Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.

fischersd

macrumors 603
Oct 23, 2014
5,269
1,815
Port Moody, BC, Canada
I have full AC 5Ghz coverage throughout my property (70'x100' lot with 1,750 sq ft house). I have had dropped calls when on cellular with my wifi signal strong (AT&T's transition from cellular to wifi issue or vise versa). When forcing wifi calling I've had issues the other side said I cut in and out, but I hear them clearly. This has gotten worse since iOS 11, but was happening even prior on iOS10 (on multiple phones).

AT&T's execution of wifi calling is a mess...
Two suggestions I have for you to try to see if they make a difference:
1) Turn off Wi-fi Assist - that may be getting into a race condition with Wifi calling. (It's in cellular options)
2) Under Cellular, go into Cellular Data Options, then Enable LTE - if your phone is set to Voice & Data, try setting it to just data.

The second option will be disabling VoLTE. I was just bouncing around a bunch of forums - it appears the threshold for switching from Cellular to Wifi for Voice may have been set lower for 4G than 3G. That may not be giving the phone enough time to switch the context so it doesn't drop the call.



I think it's entirely possible that with iOS 11 a lot of the carriers may have taken the option away in their carrier settings (or maybe Apple did, to simplify support). T-Mobile certainly had the option before - we should get someone that's on T-Mo to take a look and see if the setting is still there. (Prefer wifi calling)
 

JT2002TJ

macrumors 65816
Nov 7, 2013
1,223
685
Are you sure that's not just the option to prefer WiFi calling while roaming? That option is there normally these days, but would only apply to roaming.

No. I could just be a test market.

I also do not have prefer WiFi calling while roaming on AT&T.
[doublepost=1508783786][/doublepost]
Two suggestions I have for you to try to see if they make a difference:
1) Turn off Wi-fi Assist - that may be getting into a race condition with Wifi calling. (It's in cellular options)
2) Under Cellular, go into Cellular Data Options, then Enable LTE - if your phone is set to Voice & Data, try setting it to just data.

The second option will be disabling VoLTE. I was just bouncing around a bunch of forums - it appears the threshold for switching from Cellular to Wifi for Voice may have been set lower for 4G than 3G. That may not be giving the phone enough time to switch the context so it doesn't drop the call.



I think it's entirely possible that with iOS 11 a lot of the carriers may have taken the option away in their carrier settings (or maybe Apple did, to simplify support). T-Mobile certainly had the option before - we should get someone that's on T-Mo to take a look and see if the setting is still there. (Prefer wifi calling)

1) I always have Wi-Fi Assist off
2) This may work, but is an unacceptable work-around to a bad implementation of wifi calling. Prefer wifi calling was never an option for AT&T, even when it was in beta (I had wifi calling with AT&T when it was only in beta).
 

fischersd

macrumors 603
Oct 23, 2014
5,269
1,815
Port Moody, BC, Canada
1) I always have Wi-Fi Assist off
2) This may work, but is an unacceptable work-around to a bad implementation of wifi calling. Prefer wifi calling was never an option for AT&T, even when it was in beta (I had wifi calling with AT&T when it was only in beta).
Yep, I hear you, but it would be a good test to help isolate the problem. If your voice channel over HSPA works properly with Wifi calling and you don't have any drops, then you can give that feedback to AT&T and Apple that they need to increase the threshold that they're using for VoLTE and Wifi calling, as it's not high enough to give the phone the time to setup the context over the alternate path (ie failover).
 

IG88

macrumors 6502a
Nov 4, 2016
930
1,415
Two suggestions I have for you to try to see if they make a difference:
1) Turn off Wi-fi Assist - that may be getting into a race condition with Wifi calling. (It's in cellular options)
2) Under Cellular, go into Cellular Data Options, then Enable LTE - if your phone is set to Voice & Data, try setting it to just data.

The second option will be disabling VoLTE. I was just bouncing around a bunch of forums - it appears the threshold for switching from Cellular to Wifi for Voice may have been set lower for 4G than 3G. That may not be giving the phone enough time to switch the context so it doesn't drop the call.



I think it's entirely possible that with iOS 11 a lot of the carriers may have taken the option away in their carrier settings (or maybe Apple did, to simplify support). T-Mobile certainly had the option before - we should get someone that's on T-Mo to take a look and see if the setting is still there. (Prefer wifi calling)

Verizon, iPhone 8, iOS 11.3:
With VoLTE enabled, my iPhone 8 won't do Wifi calling if it has any sort of a LTE signal. I had to set LTE to "data only" to get Wifi calling to show up in the notification area.
 

ghanwani

macrumors 68040
Dec 8, 2008
3,722
4,295
My phones don't connect to wifi in airplane mode. It just doesn't do anything except allow my phone to charge faster

Did you try to enable WiFi after going into airplane mode? When you first go into airplane mode, it will disable all wireless interfaces, but it is possible to go in and re-enable WiFi while the device is still in airplane mode.
 
  • Like
Reactions: BigMcGuire

anitak1982

macrumors 6502a
Nov 10, 2017
547
292
West Central Ohio
Did you try to enable WiFi after going into airplane mode? When you first go into airplane mode, it will disable all wireless interfaces, but it is possible to go in and re-enable WiFi while the device is still in airplane mode.

You learn something new every day. I never tried to reconnect wifi when turning on airplane mode because it usually turns off the wifi right away. What do you know it came back on. Interesting. I won't use the wifi calling since I have unlimited with Verizon but it is good to know
 

ghanwani

macrumors 68040
Dec 8, 2008
3,722
4,295
You learn something new every day. I never tried to reconnect wifi when turning on airplane mode because it usually turns off the wifi right away. What do you know it came back on. Interesting. I won't use the wifi calling since I have unlimited with Verizon but it is good to know

You will need to do a similar thing to enable Bluetooth when you go into airplane mode, if e.g. you are using Bluetooth speakers.
 
  • Like
Reactions: anitak1982

Irishappletech

macrumors regular
Aug 31, 2017
231
16
does Wifi calling work that the phone will essentially use whichever of the 2 signals is stronger so for example if my cellular connection is quite strong but at the time my wifi isnt will it use cellular signal over wifi calling or should it use wifi calling regardless
 

ghanwani

macrumors 68040
Dec 8, 2008
3,722
4,295
does Wifi calling work that the phone will essentially use whichever of the 2 signals is stronger so for example if my cellular connection is quite strong but at the time my wifi isnt will it use cellular signal over wifi calling or should it use wifi calling regardless

From what I understand, it depends on the carrier.
 
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.