Become a MacRumors Supporter for $50/year with no ads, ability to filter front page stories, and private forums.


macrumors newbie
Original poster
Nov 28, 2022
Hey, everyone.

I've been using an iPod Touch (newest generation) in my old 2015 Ford Explorer with the Sony system, as well as my newer 2017 Ford Explorer with the Sony system for years. And years. As glitchy as both Ford Sync systems are, the voice control has worked nearly flawlessly nearly all the time on both vehicles. I press a button on the steering wheel, I hear a chime, and I'll say something like: "Play album Goodbye Yellow Brick Road", for example. And my sound system will play that album. Or song, or artist. It's the most useful feature ever. That is until my iPod Touch did its most recent iOS update a few weeks ago. Now voice control doesn't work. At all. When I try to ask it to play something all I get is a voice that says: "I didn't get that."

This is so incredibly frustrating. I had a similar experience with an iPad I had for years and years. It worked well until an update and then it simply didn't. And I had to throw it in the garbage. I just don't understand how a manufacturer can force me to update their product when it's working just fine, and then after said update, it doesn't. I feel like I'm being stolen from. Ugh!

Any help or advice or guidance would be greatly appreciated!!!



macrumors 65816
Jun 8, 2021
Try deleting it from the car and removing the BT profile on the iPod's end, then re-pair it. Might be some kind of database corruption issue.
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.