Foreign Language on Installer Windows

Discussion in 'Mac Basics and Help' started by MajorDanby, Oct 1, 2014.

  1. MajorDanby macrumors newbie

    Oct 1, 2014
    Hi all,

    Any help would be great.

    For some reason when installing new programs, the installer windows pop up in a foreign language and I have no idea why. This also happens for the dialogue box that asks me to enter my password. Please see an example below:


    I have tried resetting my PRAM (Option + CMD + P + R on startup), and then resetting my language (sudo languagesetup) but this doesn't seem to work.

    However this gives me the following error message:

    Warning: NSBundle NSBundle </System/Library/CoreServices/Language> (not yet loaded) was released too many times. For compatibility, it will not be deallocated, but this may change in the future. Set a breakpoint on __NSBundleOverreleased() to debug
    Any ideas what I can do?

    Many thanks.
  2. MajorDanby thread starter macrumors newbie

    Oct 1, 2014
  3. SaSaSushi macrumors 68040


    Aug 8, 2007
    Takamatsu, Japan
    It is Japanese. What version of OS X are you using? What is the primary language in System Prefs > Language & Region? Is Japanese on the list of preferred languages?

    Finally, what are you trying to install when this appears?
  4. MajorDanby thread starter macrumors newbie

    Oct 1, 2014

    Thanks for your help, your post has helped me figure it out. I had British English selected, however because American English was lower down the last than Japanese it was obviously defaulting to that when they was no British English text contained within the applications. I've now swapped the two around and it appears to be working.

  5. drsox macrumors 65816


    Apr 29, 2011
    Mine just says English. British English is a different setting, just as are Australian English and US English. I've never had an issue installing.

Share This Page