"Forget This Network" on one device only

Discussion in 'iOS 8' started by onepoint, Feb 6, 2015.

  1. onepoint macrumors 6502a

    onepoint

    Joined:
    Aug 3, 2010
    Location:
    USA
    #1
    Howdy -- Quick question. I have iCloud Keychain enabled on a MacBook Air, iPhone, and iPad rMini. I have a VZW hotspot (corporate-provided) that I prefer to use with my MacBook Air, but not with my iPhone (VZW unlimited data). If I try to "Forget This Network" on my iPhone, it deletes the hotspot credentials from the MacBook Air as well.

    Any way to remove specific wifi credentials from a single device, without deleting them from others? Or would I have to forego using Keychain on the iPhone to make this work?
     
  2. zorinlynx macrumors 601

    zorinlynx

    Joined:
    May 31, 2007
    Location:
    Florida, USA
    #2
    After joining the network on the Macbook Air, open Keychain Access. Find the entry for the Wifi under "iCloud Keychain", and move it over to the login or system keychain. (I forget which one does the trick)

    Then, forget the network on your phone. At this point the laptop should remember the network forever and it shouldn't get resynced to the cloud.

    Last time I did this was on Mavericks; I have no idea if it works with Yosemite but I'm sure it will.
     
  3. onepoint thread starter macrumors 6502a

    onepoint

    Joined:
    Aug 3, 2010
    Location:
    USA
    #3
    I appreciate the help.

    On the MacBook Air, there are four Keychain options:
    - login
    - iCloud
    - System
    - System Roots

    The wifi network shows up under "iCloud" and under "System". I copied the wifi network entry from iCloud over to "login". I then did "Forget This Network" on my iPhone, which seems to have deleted the entry from both iCloud and System.

    At this point I was left with the entry only in "login" and the wifi wouldn't connect. So I copied it back to System (not iCloud) and all seems to be working now.

    Hopefully that's clear (enough) to follow.

    Thanks again.
     

Share This Page