Forgot Your AndroidLock Password? How to remove it with out restore!

Discussion in 'Jailbreaks and iOS Hacks' started by TheCoolGMan, Jan 26, 2010.

  1. TheCoolGMan macrumors newbie

    Joined:
    Jan 26, 2010
    #1
    Hello! If you are reading this you to have suffered the same fate as me. Thankfully I figured out how to remove it!

    Step 1: USB Conncet your iPod Touch.
    Step 2: Since you can't SSH you can use iFunbox [Windows] or iPhone Browser [Mac] to explore your iPod's files.
    Step 3[Read carefully or you will f*ck up!]: With your iPod browser look and enter the "Library" folder. Then look for a folder in there called "Mobile Substrate" enter that and go to, "DynamicLibraries".
    Step 4: Now listen up! Find two files called, "AndroidLock.plist" and "AndroidLock.dylib" and Delete those two files only!
    Step 5: Reboot your iPod Touch and re jailbreak it if on 3.1.2 (via blackra1n)

    Now it should be GONE! You can now remove any extra bull with Cydia/Rock or disable it in SBSettings if it's still comes up. Thanks for reading, tell me if you have any problems!
     
  2. pixelated macrumors 6502a

    pixelated

    Joined:
    Oct 21, 2008
    #2
    OMG, a newbie that wants to help instead of ask stupid questions. Has hell frozen over?
    Good investigative work Gman, and welcome to the forums
     
  3. 3GBeyotch macrumors newbie

    Joined:
    Sep 25, 2009
    #3
    Awesome !

    Thanks for this I had the same problem -short term memory loss. I did an uninstall in the CLI and was able to get into my phone and rebooted and was able to get back in ok. I thought that I could just reinstall and I could set a new pattern but when I reinstall and go into the Settings->AndroidLock it asks me to enter the old pattern first which if I could remember it I wouldn't of uninstalled it in the first place.

    Any idea where it stores the old patterns? I don't believe it's in either of the two files you listed. I did an uninstall again and checked the file system for "Android*" and "android*" and came up with nothing but it's obviously still there.
     
  4. labman macrumors 604

    labman

    Joined:
    Jun 9, 2009
    Location:
    Mich near Detroit
    #4
    Wowsers

    Welcome Gman stick around nice post! saw one guy on youtube that for sure could use this. in fact you might make a video and put it on youtube.
     
  5. Kevinnijjar23 macrumors member

    Joined:
    Dec 20, 2008
    #5
    I have an easier way without any use of a computer

    Step 1: Call ur cell phone from a different phone when you anwser hit home and hang up the phone this way ur automatically into ur phone

    Step 2: go to cydia delete android lock respring your springboard

    Step 3: go download android lock again and your set

    you can choose which way to do it though
     
  6. TheCoolGMan thread starter macrumors newbie

    Joined:
    Jan 26, 2010
    #6
    This tut is more for the iPod Touches, but if you have an iPhone that is the solution.
     
  7. sixner macrumors newbie

    Joined:
    Sep 7, 2009
    #7
    Ha, so I've been toying with the patterns. Well I forgot the pattern I used now. I've uninstalled and then installed again. It's still asking for the old pattern?

    Yeah, I feel dumb. Hah.
     
  8. 3GBeyotch macrumors newbie

    Joined:
    Sep 25, 2009
    #8

    I know I said that yesterday and no one has been able to come up with anything yet.
     
  9. sixner macrumors newbie

    Joined:
    Sep 7, 2009
    #9
    I emailed the creator. Hopefully he can she some insight. I'll pass on any info.

    EDIT: recieved an answer.
    I haven't tried yet, I'm not near my computer.
     
  10. sixner macrumors newbie

    Joined:
    Sep 7, 2009
    #10
    Yes, i'm quoting myself :D

    I checked out the directory. When you open up com.zmaster.androidlock.plist it should tell you the pattern in the string. Worked just fine for me!

    Best of luck kids.
    -Sixner
     
  11. 3GBeyotch macrumors newbie

    Joined:
    Sep 25, 2009
    #11
    Yep this worked - thank you for finding the answer!
     
  12. TheCoolGMan thread starter macrumors newbie

    Joined:
    Jan 26, 2010
    #12
    Oh neat! I'll add this to the thread later on.
     
  13. vistoripod macrumors newbie

    Joined:
    Feb 9, 2010
    #14
    on my ipod

    i dont get it?? 2nd step on my ipod?? I already exited out
     
  14. vruls macrumors newbie

    Joined:
    Feb 9, 2010
    #15

    it didnt work i have windows and im using i funbox an i dont have the menu for library
     
  15. tctony macrumors 6502a

    tctony

    Joined:
    Jun 15, 2009
    #16
    I found something interesting the other day in regards to AndroidLock, in case you forget it.

    If you SSH/iFile to var/mobile/library/preferences/com.zmaster.AndroidLock.plist you can see what your lock pattern is (it uses numbers). 1-3 is first row, 4-6 is second, 7-9 is bottom.
     
  16. jeenahi macrumors newbie

    Joined:
    Mar 23, 2010
    #17
    omg!!! i thought i couldn't do anything.. but thank god. U're such a life saver!!!!!!! :D
     
  17. tuan time macrumors member

    Joined:
    Jul 8, 2009
    #18
    has anyone found a solution with the notifications blocking the clock? Or should i be looking for a custom clock that's more in the middle of the screen?
     
  18. jeff8942 macrumors newbie

    Joined:
    May 11, 2010
    #19
    i followed all the steps, however i couldnt find "Library". someone help please.
     
  19. cherishcherub macrumors newbie

    Joined:
    May 24, 2010
    #20
    i deleted androidlock after i found it annoying,

    cydia said it had been deleted...

    but when my ipod locked, android lock was still there and the previous combination didnt work.

    there is no file on my ipod

    please help...

    :apple: :confused: :confused: :eek: :eek: :mad: :mad: :apple:
     
  20. Mystikal macrumors 68020

    Mystikal

    Joined:
    Oct 4, 2007
    Location:
    Irvine, CA
    #21
    I wish this didnt cover Lockinfo, but, I dont think theres an easy way around that.
     
  21. Naethyn macrumors regular

    Naethyn

    Joined:
    Feb 6, 2010
    #22
    I forgot my AndroidLock password and then tried this, it didn't work but I found out that if you try to enter your code like fifty times instead of getting the PIN LOCKED FOR A MINUTE screen it will load up your PIN screen if you have a four digit number pin and let you get into your phone.
     
  22. reubenroyapple macrumors newbie

    Joined:
    Jul 23, 2010
    #23
    Activator

    download activator from cydia. on activator, go onto the "Anywhere" tab and scroll to "lock/unlock" on that select whatever you want, suck as swipe bottom left hand corner. in the lock screen, swipe bottom left hand corner, and it will bypass the android lock. then go on cydia and delete it :) :apple: 
     
  23. wiiareonfire macrumors newbie

    Joined:
    Nov 16, 2008
    Location:
    Atlanta Metro Area
    #24
    I had this problem. I went into the .plist and used the password that was laid out. It didn't work. I changed the code, rebooted, and viola! Thanks! (Totally uninstalling this thing)
     
  24. Yansen macrumors newbie

    Joined:
    Feb 6, 2011
    #25
    You are a GENIOUS!!!:eek: :p
     

Share This Page