Formatted Fusion drive only shows 500GB?

Discussion in 'iMac' started by spinstorm, Jun 9, 2017.

  1. spinstorm, Jun 9, 2017
    Last edited: Jun 9, 2017

    spinstorm macrumors 65816

    Joined:
    Sep 14, 2007
    #1
    Anyone have any suggestions?

    I tried to reformat and reinstall my old iMac but I ran into a problem. I had the 1TB fusion drive partitioned as 2 x 500GB; I formatted one partition and then tried to combine the partitions and reformat in disk utility through the recovery partition.

    But it froze so after 30 mins I powered it off and on again and now disk utility can only see half the HDD - I have been through every setting I can see and I can’t find a way to get it back to the full size.
     
  2. CWallace macrumors 603

    CWallace

    Joined:
    Aug 17, 2007
    Location:
    Seattle, WA
  3. spinstorm thread starter macrumors 65816

    Joined:
    Sep 14, 2007
    #3
    You are correct. I just took it to an Apple Store and the genius spent an hour on terminal fixing it.

    I could have done it myself but he did a great job. One benefit of him doing it is he reinstalled the OS from an image which was much faster than I could do it having to download and reinstall it.
     
  4. ZipZap macrumors 601

    Joined:
    Dec 14, 2007
    #4

Share This Page