Formatting a Seagate 1TB Expansion drive, error "file system formatter failed"...?

Discussion in 'Mac Basics and Help' started by emilyroyal, Apr 25, 2010.

  1. emilyroyal macrumors newbie

    Joined:
    Apr 25, 2010
    #1
    I'm trying to format a new external hard drive and it is not working.

    It is a Seagate 1TB Expansion drive.

    The box only says PC and Windows, but the guy said 'it should work on a mac too, as long as you format it on a mac', and other people on the internets say it should be fine also eg here.

    So, when i go into Disk Utilities > Erase tab > change Volume Format to Mac OSX Extended > click erase, it gets about 2% in and then an error window pops up which says "Disk Erase failed. Disk Erase failed with the error: File system formatter failed."

    What am I doing wrong? I don't even understand the error msg, and I have already read through quite a few threads but haven't found anything...

    This is what happens:
    [​IMG]
     
  2. RHVC59 macrumors 6502

    RHVC59

    Joined:
    May 10, 2008
    Location:
    Eugene, Oregon
    #2
    Not sure but I would try to format the disk3s1. that may help...
     
  3. Kingcodez macrumors 6502

    Kingcodez

    Joined:
    May 13, 2009
    Location:
    China
  4. edward.ish macrumors newbie

    Joined:
    May 5, 2010
    #4
    I'm having the exact same problem, have tried formatting the disk3s1 but that doesn't seem to make any difference.

    Does anyone have any other ideas?

    Never had this problem with an external HD before.
     
  5. koalaelf macrumors newbie

    Joined:
    Sep 14, 2010
    #5
    Hi there,

    I have just bought one of these Seagate Expansion 1TB drives & I am having exactly the same problem as you. Did you resolve the problem in the end? I would appreciate any info you have. Thanks!
     
  6. TonyPayne macrumors newbie

    Joined:
    Sep 26, 2010
    #6
    Had precisely the same issue. Ended up solving it by doing the following (in OSX 10.5.8):

    - in disk utility, go to the partition tab (not erase)
    - under 'volume scheme' choose 2 partitions (choosing 1 doesn't work)
    - size and name your partitions
    - use the normal Mac OS Extended (journaled) format
    - click 'apply'

    No problems from there on.

    TP
     
  7. qtiavcm macrumors newbie

    Joined:
    Apr 22, 2008
    #7
    yup!!! I tried it and it worked like a charm.... but right after that what I did was to choose 1 partition and then mac os extended journaled format....
    what do you know? it worked perfectly!
    thank you guys.... I'm going to hit the beach and hit the waves now :D:apple:
     
  8. qtiavcm macrumors newbie

    Joined:
    Apr 22, 2008
    #8
    an I forgot to mention that the file transfer increased to a bloody nice speed too..... gotta go....the weather is perfect:cool:
     
  9. darktraining macrumors newbie

    Joined:
    Dec 16, 2010
    #9

    That's kind of a waste of space, I posted a howto on my site (http://aliencgi.com/mac/73/) but in short, all you need to do is set the partition to one, change the option to GUID partition and you can keep the entire drive formatted without losing 200GB.
     
  10. phased macrumors member

    Joined:
    Jun 10, 2009
    #10
    hi all,

    i'm in a very similar position to the OP, only i've tried this fix here (a number of times) and still no luck. i've even tried doing it in recovery mode and safe boot to no avail.

    drive was previously partitioned using this method without issue. and yes, i'm trying to partition it after giving it a clean erase.

    has my HD gone haywire?

    thanks,
    thom.
     
  11. ewen31 macrumors newbie

    Joined:
    Feb 17, 2014
    #11
    Im having exact same problem as Phased.

    Followed all the tuts to partition/guid mode etc but to no avail.

    Any help??
     
  12. trevorbsmith macrumors member

    Joined:
    Dec 17, 2007
    #12
    I have a GoFlex 2 TB drive. It's a piece of **** and I have had nothing but trouble with it since I got it. Time Machine kept failing on it, eventually it would not even mount properly just to do drag and drop to it. Now I cannot erase or partition it, as per the comments of the other posters in this thread in the past few years.

    My advice: never buy one of these Seagate drives for use on a Mac. Ever.

    How to fix? Great question. Is there no tool on a Mac that is similar to the "get down to the guts" types of tools available on Linux? There were times years ago that I used a Linux box to do some low level type of partitioning or repairing of tables that allowed me to get drives working on a Mac again.

    Seriously, I have 2 TB of a drive that is totally useless. What a drag.
     
  13. Dudley73 macrumors newbie

    Joined:
    Jan 8, 2015
    #13
    Dudley73

    Hi everyone,

    Wish I'd found this thread before buying a Seagate 1T!!

    Formatting for Mac OSX I get as far as 'apply' and within 4 or 5 seconds I get 'Partition failed with the error: Could not unmount disk!

    Whatthe? Any ideas?

    D
     
  14. mattytwills macrumors newbie

    Joined:
    Feb 9, 2015
    #14
    This solved this exact problem. Thank you so much! Genius
     
  15. Bigj6362, Jul 8, 2015
    Last edited: Jul 8, 2015

    Bigj6362 macrumors newbie

    Joined:
    May 2, 2015
    #15
    Same thing here. I just bought my 4th 1TB SSHD from seagate. two worked, and two did not. the fourth one I RMA'd as defective.

    (EDIT)
    I got it working!!! FINALLY!

    1. I booted of a Linux live CD (I happened to have a Suse 13.2 disc lying around but there are plenty of others that will do the job, probably easier).
    2. Formatted the drive using gparted as a fat32 drive
    3. Booted back into OS X
    4. open Disk Utility and formatted the Drive entry (not the partition label). Formatting the partition didn't work for me. It complained about needing more space.

    Done. Maybe that is another way for people to get this drive working outside of the previous options listed. It worked for me anyway.
     
  16. wanderbebo macrumors newbie

    wanderbebo

    Joined:
    Aug 17, 2015
    #16
    I have a seagate 1 tb external expansion drive, and when trying the 2 partition method listed above it gives me an error code saying- POSIX reports: The operation couldn’t be completed. No such file or directory
    Any thoughts?
     

Share This Page