Formatting Excel Date Error

Discussion in 'Mac Apps and Mac App Store' started by RatHat, Jun 28, 2013.

  1. RatHat macrumors member

    Joined:
    Jun 29, 2011
    #1
    I have a strange formatting error in Excel 2011 for Mac which happens when I try to format cells as Date.

    If I right click on a group of cells or a column and choose Format Cells, then in the dialog, Date, and choose any of the preset formats such as; dd/mm/yy the result never includes the correct year, or month.

    For example, if I enter 29.6 into a cell the result would be 29/01/00

    If I enter 29/6 then the result comes out as 29/6

    I have checked the preferences, and cannot find anything that will allow me to change the date preferences in Excel other than to use the 1904 date system.

    Anyone have any idea how to fix this?
     
  2. Pharmscott macrumors 6502a

    Pharmscott

    Joined:
    Dec 13, 2011
    Location:
    Sacramento, CA
    #2
    In the dialog box when formatting the cells, what country do you have selected? Also, what country are you in? Entering a date as 29.6 would be atypical in America but certainly there are lots of possibilities.

    Playing with Calendar Type might help too (but I'm not experienced on this).
     

    Attached Files:

  3. RatHat thread starter macrumors member

    Joined:
    Jun 29, 2011
    #3
    I am based in Indonesia at the moment, and have tried setting the location to Indonesian English, also tried setting it to UK, Wales, Scotland and so on. All to no avail.

    The only calendar option I have is Western. No others unfortunately.
     

Share This Page