Formatting portable drive takes days with disk utility

Discussion in 'MacBook Pro' started by D3Rk, Aug 6, 2011.

  1. D3Rk macrumors newbie

    Joined:
    Aug 6, 2011
    #1
    For the past five days I've been trying to get my new WD Elements portable HD to work with my new MacBook Pro. I am using Disk Utility to partition the HD (being 1 TB in size). However, this process is taking 3 days now and nothing seems to happen.

    The progress bar in disk utility seems to be stuck halfway but the program itself is still active. When I stop the process (by quitting disk utility) nothing happens. The program shuts down but the HD is nog longer visible in both Mac OSX Lion and in Windows. It is still there as disk utility does list it in the connected drives list - but it simply doesn't format it.

    At first I thought it was the disk itself so I got a new HD (and sent the old one back) but that hasn't solved the problem.

    Obvious question is: what's going wrong and how can I fix it?
     
  2. Mr. Retrofire macrumors 601

    Mr. Retrofire

    Joined:
    Mar 2, 2010
    Location:
    www.emiliana.cl/en
    #2
    It is probably a firmware bug in the USB/FireWire translation bridge. I never used "ready-to-use" disks, because i want to know what i use, and you can find a lot of horror stories about many "ready-to-use" disks on the Internet (mostly Seagate and Western Digital). Most manufacturers of the "ready-to-use" disks do not even tell you, which hard disk and which bridge controller they use.

    I'm pretty happy with my two InXtron FW800 enclosures, one with a WD Green (WD20EARS, 64 MB cache, 4k sectors) and one with a WD Black (WD2001FASS, 64 MB cache, 7200 rpm). I've also a 2.5" enclosure (SK-2500 series).
     
  3. BAC5.2 macrumors regular

    Joined:
    May 16, 2011
    #3
    I had this happen once or twice. I simply formatted the drive in NTFS on a PC, then reformatted it in HFS+

    Worked fine.
     

Share This Page