Formatting problem with new external drive

Discussion in 'Mac Accessories' started by lamemodem, Mar 20, 2008.

  1. lamemodem macrumors member

    lamemodem

    Joined:
    Apr 5, 2005
    #1
    I just purchased a new 750GB Seagate FreeAgent drive. I hooked it up via FireWire 400, opened Disk Utility and tried to format it as Mac OS Extended (Journaled). It gave me an error message saying it was the wrong format (or something like that - I can't remember exactly). I tried every Mac OS option and it gave me the same error message.

    So I tried the MS-DOS FAT option and clicked erase. It erased it in a few seconds. Then I tried the Mac OS Extended (Journaled) option again. For over an hour the Disk Utility screen has looked like the attached screen shot. If I try to quit Disk Utility it tells me it has an operation in progress.

    Note the part at the bottom: newsf_hfs: /dev/rdisk1s1: partition size not a multiple of 4k.

    What should I do? Let it continue to work? Unplug it and start over? Is it even doing anything?

    Thanks.
     

    Attached Files:

  2. Cave Man macrumors 604

    Cave Man

    #2
    The drive is likely initialized as NTFS. In Disk Utility, select the drive (and NOT the partition that is below it and indented.) Select the Partition tab and then choose 1 partition (or more, if you like) from the pull-down menu. If you plan to boot an Intel-based mac with this drive it is essential that you set GUID table from the Options button. If PPC mac, then choose the Apple table. After that, set to HFS+ with Journaling and initialize.
     
  3. lamemodem thread starter macrumors member

    lamemodem

    Joined:
    Apr 5, 2005
    #3
    That did the trick. Thank you so much for your quick reply.
     
  4. dubhe macrumors 65816

    dubhe

    Joined:
    May 1, 2007
    Location:
    Norwich, UK
    #4
    Mroogle

    This is why I love MacRumors, I had the same problem, searched on MRoggle and fixed within minutes. If you can't fix it, MRoogle it!
     
  5. lord patton macrumors 65816

    lord patton

    Joined:
    Jun 6, 2005
    Location:
    Chicago
    #5
    +1. Quick little search in macrumors and the problem is solved.

    In fact, my purchase of the 1 TB FreeAgent Extreme was because it was mentioned as on sale at Fry's this week ($130).

    Search *is* my friend! ;)
     
  6. BeeJay G2 macrumors newbie

    Joined:
    Aug 5, 2009
    Location:
    Copenhagen, Denmark
    #6
    Same problem setting up a SohoRaid

    I've just been setting with the same problem, on my Stardom SR3620-2S-SB2
    sohoraid. I'm trying to set it in Raid 1 ( mirroring ) but has been getting errors
    when I set it in Mac OS-Extended, when I start "erase". It comes up with the error, and set the volume format to MS-DOS ( fat ) This has gone on for some time, but now it's had the same "message" as lamemodem.
    newsf_hfs: /dev/rdisk1s1:
    I can see that "Cave Man" came up with a answer, but I could't get how I should stop the operation, as I get a warning that stopping the operation can lead to damage on disk, while it's in progress!??
    Should I just "pull the plug" and stop it....

    Thank's
    BeeJay
     

    Attached Files:

  7. pmcmvp macrumors member

    Joined:
    Jul 28, 2009
    #7
    yes this did the trick for me as well! thanks!
     

Share This Page