Formatting Problems on Additonal Hard Drive

Discussion in 'Mac Pro' started by robotartfashion, Feb 10, 2009.

  1. robotartfashion macrumors 6502

    Joined:
    Jan 1, 2009
    Location:
    Phoenix, AZ
    #1
    Ok, this may be the wrong forum section for this, but seeing as it's occuring on my MacPro and there are generally more advanced users in here,

    I have a 640GB WD Black hard drive in my computer, and that I had accidentally formatted during my creation of a XP boot camp drive (I have another hard drive in the MacPro with this present)

    At the time I lost a majority of my media and had to rerip it all (learned my backup lesson there)

    So when it was reformatted it was changed from OSX extended journaled to MS-DOS Fat

    I then used the drive to store the media on again as I reripped and pulled some from Time Machine.... I kept running into problems where some files would not copy over

    So I reformatted a different drive and copied all the media to it, which fixes the other issues, and now I'm trying to reformat the MS-DOS 640 GB drive back to osx extended journaled

    Whew....

    When I use disk utility I select the drive, and change the volume format from MS-DOS (FAT) to Mac OS Extended (Journaled) and click Erase

    ......and then it stops and says "Disk Erase failed Disk erase failed with the error: File system formatter failed"

    I tried googling, any ideas?
     
  2. UltraNEO* macrumors 601

    UltraNEO*

    Joined:
    Jun 16, 2007
    Location:
    近畿日本
    #2
    I managed to do something like this last week, though I was moving a HD from one system to another.

    [​IMG]
    [​IMG]
     
  3. robotartfashion thread starter macrumors 6502

    Joined:
    Jan 1, 2009
    Location:
    Phoenix, AZ
  4. surflordca macrumors 6502a

    surflordca

    Joined:
    Nov 16, 2007
    Location:
    Ontario, Canada
    #4
    We have some smart users here at MacRumors. That is why I try to be here every day and catch up on my reading :D:D
     
  5. 119576 Guest

    119576

    Joined:
    Aug 6, 2007
    #5
    This just worked for me after I had the same problem.
    Thanks a lot. :)
     
  6. 2056 macrumors 6502

    Joined:
    Sep 10, 2008
    #6
    i was having this exact issue this evening. thank you so much!
     
  7. bigjash macrumors newbie

    Joined:
    Mar 22, 2010
    #7
    Ditto on the good tip! I just plugged in a 2TB Seagate Exchange via USB. It would not allow me to re-format the usual way.

    Changed the partition option and VOILA!

    Thanks for the help.
     

Share This Page