Forums look different in Safari for Windows

Discussion in 'Site and Forum Feedback' started by dcv, Jun 12, 2007.

  1. dcv macrumors G3

    Joined:
    May 24, 2005
    #1
    So I downloaded the new Safari 3.0 beta for Windows this morning and started browsing the forums, amazed by the speed.

    Then I noticed things were looking a little different - there's no "Quick Links" option in the top menu and the "Mark Forums Read" and "Open Buddy List" links are showing in the top menu. Also when I open a thread I'm seeing thread tools such as the search and rating options at the bottom of the screen instead of the usual link at the top.

    I thought that there'd been a vBulletin update overnight or something but just switched back to Opera and the forums look normal again!

    Is anyone else seeing this or has it loaded a different stylesheet for Safari or something? :confused:

    (attachments below show the Safari menu + search options vs what I usually see in Opera)
     
  2. ebouwman macrumors 6502a

    Joined:
    Jan 5, 2007
    Location:
    Canada
    #2
    i guess that thats why its still a beta :p
    I'll still get it for my windows computer though:D
     
  3. lancestraz macrumors 6502a

    lancestraz

    Joined:
    Nov 27, 2005
    Location:
    RI
    #3
    I don't see "Open Buddy List" or "Mark Forums Read" in Safari 2. But they are there in Safari 3. Weird.
     
  4. dcv thread starter macrumors G3

    Joined:
    May 24, 2005
    #4
    It's a vBulletin issue; there's a little mention of Safari for Windows on their forums here...

    Post 20 looks interesting. It applies to vB 3.6.7 and we appear to be on 3.6.5 but perhaps it would also apply - it just explains that vBulletin isn't properly detecting the browser so some of the navigation menus are disabled and replaced with alternative links.

    Not a huge problem at all but just wanted to draw it to the attention of the Site Admins as it was confusing me this morning!

    :)
     
  5. Doctor Q Administrator

    Doctor Q

    Staff Member

    Joined:
    Sep 19, 2002
    Location:
    Los Angeles
    #5
    It's not Safari 3, it's not vBulletin, and it's not evil spirits (although they are often the cause of forum glitches). It was a side effect of the problems (reported in other Feedback threads) with some of our extra round-robin servers yesterday.

    Here's what happened:
    • You fetched a forum page.
    • vBulletin returned you the page, which required that a set of files be fetched -- all that stuff you see in the Activity window.
    • For at least one of the Javascript files, your fetch request was assigned to one of the troublesome servers, so you didn't get the file.
    • You were left with a complete-looking page, but without some of the scripting behind it.
    • When you tried to use a feature that relies on Javascript, such as the drop-down menus, you were given the no-Javascript version, such as searches being sent to the bottom of the page. You might notice a string like "nojs" in the URL.
    • Refreshing the page would eventually fix it, since you'd sometimes get the complete set of files from more cooperative servers.
    Since we're back to our normal servers, this symptom should no longer occur.
     
  6. yagran macrumors 6502a

    Joined:
    Jan 8, 2007
    Location:
    Brighton, East Sussex, UK
    #6
    doctor q gives the definitive diagnosis, thanks doc
     
  7. dcv thread starter macrumors G3

    Joined:
    May 24, 2005
    #7
    Ahhh okay then, thanks Doctor Q. I'll check in the morning to see if it's fixed.
     
  8. rockthecasbah macrumors 68020

    rockthecasbah

    Joined:
    Apr 12, 2005
    Location:
    Moorestown, NJ
    #8
    Another little qwerk i just noticed from Safari on Windows for MR, when you click on a member's linked name, the menu does not appear that prompts you whether you want to view their profile, send a private message, etc, it just goes directly to their profile.

    :eek:
     
  9. 840quadra Moderator

    840quadra

    Staff Member

    Joined:
    Feb 1, 2005
    Location:
    Twin Cities Minnesota
    #9
    Two forums I admin (also vBulletin) have similar issues too.
     
  10. dcv thread starter macrumors G3

    Joined:
    May 24, 2005
    #10
    Yeah still the same thing, forums look different in Safari (Win) but normal in every other browser (Mac/Win), I think it's a vB issue.
     
  11. mad jew Moderator emeritus

    mad jew

    Joined:
    Apr 3, 2004
    Location:
    Adelaide, Australia
    #11
    I don't get the drop down list form the Search button in the menu bar thingo. It's obviously no huge issue, just a bit odd.
     

Share This Page