Forums Slow To Load (Among Other Things)

Discussion in 'Site and Forum Feedback' started by Scepticalscribe, Apr 27, 2017.

  1. Scepticalscribe, Apr 27, 2017
    Last edited: Apr 27, 2017

    Scepticalscribe Contributor

    Scepticalscribe

    Joined:
    Jul 29, 2008
    Location:
    The Far Horizon
    #1
    Today, I have noticed that the forums have been very slow to load at times.

    Not only that, but they stall, and hang - one of the consequences of which are double posts, as one is not sure that a post has been actually successfully posted when one has pressed 'post reply' because the system stalls and hangs.

    Initially, I thought it was simply my connection, but - scrolling through the forum - I have spotted several cases of duplicated and triplicated posts, which means that I think the problem may be far more widespread that I had initially thought.
     
  2. Scepticalscribe thread starter Contributor

    Scepticalscribe

    Joined:
    Jul 29, 2008
    Location:
    The Far Horizon
    #2
    Forums slow, and hanging, suspended - and difficult to 'open' or get access to the forums section of the site again today.
     
  3. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #3
    I had issues yesterday as well, but as of right now, I'm not seeing any performance issues.
     
  4. Michaelgtrusa macrumors 604

    Michaelgtrusa

    Joined:
    Oct 13, 2008
    Location:
    Everywhere And Nowhere
    #4
    Forum was offline for me for perhaps ten min? back now.
     
  5. Weaselboy Moderator

    Weaselboy

    Staff Member

    Joined:
    Jan 23, 2005
    Location:
    California
    #5
    I was seeing the slowness and double posting yesterday also.

    The forums just came up from about a 30 minute outage here. Admins are aware of both issues.
     
  6. willmtaylor macrumors 604

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    A Natural State
  7. AngerDanger macrumors 68030

    AngerDanger

    Joined:
    Dec 9, 2008
    #7
    Today, the main site has been working fine, but earlier, the forums would hang when I tried to load them. If they ever stopped hanging, I'd get an error:

    Screen Shot 2017-04-28 at 11.15.30 AM.png

    To see if it was a regional thing (which I don't think it was given that users from diverse locations have reported this), I tried loading it through a proxy, and got a similar error:

    Screen Shot 2017-04-28 at 11.15.16 AM.png
     
  8. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #8
    Just to follow up on this, we did have a server issue that resulted in some downtime on Friday. We should be running normally now, but let us know if anyone continues to see performance issues.
     
  9. Scepticalscribe thread starter Contributor

    Scepticalscribe

    Joined:
    Jul 29, 2008
    Location:
    The Far Horizon
    #9
    I am - as it happens, just today; I have experienced slow loading of the site, stalling, hanging, and so on.

    In practice, this afternoon, so far, I have had to close the site completely, and try to re-enter; I have also switched off the internet connection on the computer, (and then attempted to access the site), and - on a number of occasions - I have had to go back a page or two and then try to re-load the page - or thread - I had attempted to gain access to a few minutes earlier.
     
  10. Scepticalscribe thread starter Contributor

    Scepticalscribe

    Joined:
    Jul 29, 2008
    Location:
    The Far Horizon
    #10
    One thing I find that sometimes contributes to this experience of the forums being slow, and stalling, hanging - and seizing up, when on MR, and trying to get access to the forums - is that the forums will often freeze and stall and hang when an alert flashes up.

    Indeed, at times, I have been tempted to disable the 'alert' function (and feature).
     
  11. organicCPU macrumors regular

    organicCPU

    Joined:
    Aug 8, 2016
    #12
    Can't access the forum anymore on Mac OS X 10.8.x Mountain Lion with Safari 6.2.8.

    As Firefox 45.9.0 ESR is still working, I expect MR switched to TLS v1.2 recently.
    Too bad for surfing on even older Mac OSs... Does anyone have a hack for old Safari talking modern encryption?
     
  12. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #13
    Our CDN on the news side turned off TLS 1.0/1.1 support a few days ago, cutting off access to older versions of Safari, but the forums were still okay. We've asked them to turn it back on for the time being, but no guarantees on how long it will remain supported.

    I'll have to look into whether a similar change was made on the forums, but it sounds like it.
     
  13. organicCPU macrumors regular

    organicCPU

    Joined:
    Aug 8, 2016
    #14
    Amazing! The forum works, the frontpage doesn't. Thanks for looking into this!
     
  14. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #15
    Is the front page working for you now? There's another user who was running into the issue and it's working for him, so hopefully everything is working at this point.
     
  15. Scepticalscribe thread starter Contributor

    Scepticalscribe

    Joined:
    Jul 29, 2008
    Location:
    The Far Horizon
    #16
    Here is another slight oddity: The front page has ads on it (and I'm a contributor, so I assumed that when I visit the site that I am not assailed by ads) whereas the rest of the site doesn't.
     
  16. WildCowboy Administrator/Editor

    WildCowboy

    Staff Member

    Joined:
    Jan 20, 2005
    #17
    If you're a contributor and signed into the forums, you should be able to just hit this URL to set the cookie that will make front page ads disappear:

    https://www.macrumors.com/?ads=0
     
  17. Scepticalscribe thread starter Contributor

    Scepticalscribe

    Joined:
    Jul 29, 2008
    Location:
    The Far Horizon
    #18
    Thank you. Much appreciated.

    It seems to have improved, for now.

    I had wondered whether I would need to add Adblock (which I used to have installed on my computer).
     
  18. organicCPU, May 4, 2017
    Last edited: May 4, 2017

    organicCPU macrumors regular

    organicCPU

    Joined:
    Aug 8, 2016
    #19
    Yes, the front page is working again! Thank you so much!

    EDIT: Later today, the front page stopped working again on 10.8.x Safari.
     
  19. Scepticalscribe thread starter Contributor

    Scepticalscribe

    Joined:
    Jul 29, 2008
    Location:
    The Far Horizon
    #20
    Forums slow, stalling and stuttering again, with the dreaded 'double posting' also making an appearance.

    In my case, I find that the 'alerts' can be very destabilising; if I click on an alert, the system frequently stalls on days when it is already quite slow.
     
  20. willmtaylor macrumors 604

    willmtaylor

    Joined:
    Oct 31, 2009
    Location:
    A Natural State
    #21
    I haven't had any issues this morning (or evening in @Scepticalscribe 's case).
     
  21. Scepticalscribe thread starter Contributor

    Scepticalscribe

    Joined:
    Jul 29, 2008
    Location:
    The Far Horizon
    #22
    I have noticed that the site is stalling & freezing horribly today - and is especially difficult when trying to click on the 'like' button, or when an alert comes in.
     
  22. Scepticalscribe thread starter Contributor

    Scepticalscribe

    Joined:
    Jul 29, 2008
    Location:
    The Far Horizon
    #23
    Just thought I'd mention that I have noticed that both yesterday and today that the forums have been slow to load, unstable, and stalling frequently.

    It has been easier to leave the forum and attempt to re-enter, than to turn pages in threads.
     
  23. Scepticalscribe thread starter Contributor

    Scepticalscribe

    Joined:
    Jul 29, 2008
    Location:
    The Far Horizon
    #24
    Just wanted to note tat the forums part of the site have been very slow to load for the past few days.
     

Share This Page