Found a PowerMac G4

Discussion in 'PowerPC Macs' started by Bocaj, May 10, 2010.

  1. Bocaj macrumors member

    Joined:
    Feb 17, 2010
    #1
    So while walking my dog, someone decided that their PowerMac G4 was of no use to them anymore, or maybe it wasn't working. Found it at the end of the driveway, knocked on their door for a few minutes and no answer.

    So I took the thing, tried plugging it in and the power light goes on for a second and it doesn't turn on. I'm HOPING and assuming that it would be a simple, cheap fix.

    Anyone have a problem similar to this with their G4's?
    Is it worth repairing? Meaning, the hardware isn't too old for surfing at the least and maybe photoshop CS3 or CS4?

    Gotta say, it's great having a dog, I have found all kinds of great things while taking her out for walks...plus it helps to destress me quite a bit, the sights the sounds.
     
  2. BobD2 macrumors member

    Joined:
    Aug 9, 2008
    Location:
    Massachusetts
    #2
    I've had this problem with my Mac. I have a dual 800 MHz G4 PowerMac (2001 vintage, I think). This has happened to me a couple of times following a power failure. There is a reset button that you can push -- PMU reset I think. You can find instructions as to how to find this and how to reset it at www.apple.com (might have to search for it). It's been a while since I have done this, so I am reluctant to attempt to provide detailed instructions. Better to look this up and follow directions. But it has worked for me following the exact same symptoms you describe. As simple as pushing a button.
    Here's something to get you started:
    http://docs.info.apple.com/article.html?artnum=95037
    and:
    http://reviews.cnet.com/8301-13727_7-10343127-263.html?tag=mncol
    Look these over and see if they help. But perhaps do a bit more searching before trying something.
    Good luck!
     
  3. Bocaj thread starter macrumors member

    Joined:
    Feb 17, 2010
    #3
    That worked...to a degree.
    It'll start up, but I'm just staring at a black screen and the power button light will flicker on and off twice then stay on and cycle through like that until I turn it off completely.

    I'm assuming it may be the video card?

    But man is this thing noisy.
     

Share This Page