Found a solution to iPhone 4 upgrade to 4.0.1 error [PC]

Discussion in 'iPhone Tips, Help and Troubleshooting' started by KidFresh, Jul 17, 2010.

  1. KidFresh macrumors regular

    Joined:
    May 11, 2009
    Location:
    NYC
    #1
    I kept getting error (1004) after upgrading to OS 4.0.1 when I was attempting to restore from backup. Nothing I could do to get my phone out of recovery mode until...

    I've finally found a solution to get your iPhone 4 "unbricked".

    http://thefirmwareumbrella.blogspot.com/

    Just download the appropriate version through links posted on the left side of webpage.

    Run "Umbrella-4.01.01.exe" -- Kick Device Out Of Recovery

    You'll already have OS 4.0.1 on your phone. In iTunes, restore from backup.

    ********************************************************

    For those that have been having a similar issue...

    I think it's completely absurd that I have to resort to using third-party programs to get my phone working properly again.

    Many users have called Apple support in attempt to resolve their problems and have been told to go see Genius Bar at Apple stores. The Genius reps have been unable to fix the problem and are handing out new replacements. What a sad fiasco.
     
  2. daristan macrumors newbie

    Joined:
    Sep 12, 2010
    #2
    I really need to say a BIG THANK YOU for sharing this.
    I have the same problem today with error 1004 and even the itunes restore give me the same error which make my iphone 4 a brick.
    I tried your link but the latest version does not work until i find the version which you have mention which then work like a breeze. thanks.
     
  3. mrpuffy macrumors newbie

    Joined:
    Sep 4, 2010
    #3
    THanks very much, been searching for solution. [​IMG] You should post on other forums so people know!
     

Share This Page