Found a way to add airprint support back to 10.6.5

Discussion in 'iPad' started by tac22, Nov 10, 2010.

  1. tac22 macrumors 6502

    Joined:
    Jun 16, 2009
    #1
  2. magga macrumors regular

    Joined:
    May 14, 2009
    #2
    I tried this, but unfortunately it didn't work and had issues reinstalling the printer as it couldn't find it and now it doesn't work at all!

    Good job I backed up the old files :)
     
  3. topher2889 macrumors regular

    topher2889

    Joined:
    Jun 1, 2007
    Location:
    Wisconsin
    #3
    could someone please just upload these three files so I don't have to go and download an entire prerelease build? Sorry to be that guy :eek:
     
  4. magga macrumors regular

    Joined:
    May 14, 2009
    #4
    Further to my last post, I have now got it to work from my iPad and iPhone however the rumours about it being flakey aren't rumours! It has randomly stopped seeing the printer now despite it working 5 minutes previously.

    I'll upload the files tomorrow if no one else has but it's 5am here now, and I need some sleep!
     
  5. imacken macrumors 65816

    Joined:
    Feb 28, 2010
    #5
    You'll find the 3 files on the 9to5mac link above.
    Works perfectly for me.
     
  6. Zcott macrumors 68020

    Joined:
    Oct 18, 2009
    Location:
    Belfast, Ireland
    #7
    I can confirm this does work! My setup below:

    10.6.5 upgraded from 10.6.4, without any of the betas.
    iPad running 4.2 GM upgraded from Beta 3.
    HP C4400 connected via USB to an Airport Express.
    Shared through my MacBook Pro.

    Downloaded the files, installed them, rebooted, shared the printer through my Mac, and now I can print from my iPad.
     
  7. Chupa Chupa macrumors G5

    Chupa Chupa

    Joined:
    Jul 16, 2002
    #8
    I saw this posted last night and thought it was worth a try. It was most definitely. Works great for me.

    What I did:

    1) Used Pacifist to extract the mentioned files
    2) Installed the files to their proper location in the public release 10.6.5
    3) Uninstalled my printers
    4) Restarted MP
    5) After it booted back up 10.6 took the liberty to reconnecting my printers so I turned on my iPad, launched Safari. The printer (a Brother 5280DW) that is physically connected to my MP show up. I selected it and and printed a random page. A few seconds later a Wikipedia report was spewing out.

    I hope Apple puts this functionality back in, but if it doesn't, I hope they don't intentionally cripple this "hack."

    BTW if you don't feel like typing out commands in terminal to view the invisible folders there is a great widget called "Hidden Files". Once you install it you just push a button and it will basically do all the back end stuff for you. Be aware sometimes it will just give you a blank screen -- don't freak, just press the button again.
     
  8. MRU Suspended

    MRU

    Joined:
    Aug 23, 2005
    Location:
    Other
    #9
    ^ Easiest solution is to use Go.


    Finder Menu bar > Go > Go To Folder

    Type in the address (copy and paste) there and hey presto.

    No terminal required. ;)
     
  9. topher2889 macrumors regular

    topher2889

    Joined:
    Jun 1, 2007
    Location:
    Wisconsin
    #10
    Added the files and now AirPrint is working flawlessly on my Brother HL-2170W connected through WiFi and shared through my MacBook. Hooray!
     
  10. guywoodman7, Nov 11, 2010
    Last edited: Nov 11, 2010

    guywoodman7 macrumors member

    Joined:
    Jan 28, 2008
    Location:
    New York
    #11
    Worked for me too. I'm running the actual release of 10.6.5. Never used any OS X beta's prior. Also running 4.2GM on my iPad. Followed the instructions and had no issues what so ever. Can now print from my iPad.

    Edit: Forgot to mention that my printer is an Epson Stylus Photo RX595
     
  11. Crosbie macrumors 6502a

    Crosbie

    Joined:
    May 26, 2010
    Location:
    Brighton, UK
    #12
    Works on Epson Stylus 600FW Wireless - only when Mac is on via sharing.

    iPad still shows the printer on AirPrint even when Mac is off; but when you print, the interface freezes and ultimately you get an error message popup (printer is offline). This happened outside the app, so printing apparently continues in the background.

    Quite why this can't just work via wireless rather than sharing with an intermediate Mac, I don't know.

    Anyone tried with an AirPort-connected printer, btw? Should this work?
     
  12. sapporobaby macrumors 68000

    sapporobaby

    Joined:
    Sep 27, 2007
    Location:
    3 earth minutes from your location....
    #13
    The problem with this is that not everyone has the original beta disk image. Anyone find the files out on the net anywhere? Please do not post a link, just if they are there. Thanks in advance.
     
  13. Cougarcat macrumors 604

    Joined:
    Sep 19, 2003
    #14
    Yes, it's working with my Airport Express.

    Sapporobaby, someone posted a link on the big 10.6.5 thread.
     
  14. Ramsteiner macrumors member

    Joined:
    Sep 3, 2007
    #15
    Don't forget the obvious - two hours later - make sure you are on the same wireless network. (shaking his head - duh!)
     

Share This Page