Resolved Found folder/file cannot be located or deleted - fixed while writing

Discussion in 'macOS' started by simsaladimbamba, Mar 12, 2013.

  1. simsaladimbamba

    Joined:
    Nov 28, 2010
    Location:
    located
    #1
    DISCLAIMER: This thread has been solved while writing it. It is just here for future prosperity and if someone might find it and need a fix, which is posted at the bottom of this post.

    Hello.

    I was just doing an update on my Uninstall Applications video using Mac OS X 10.6.8 and wanted to use Skype as reference to completely delete it, I came upon a strange behaviour I haven't encountered in the past nine years since using Mac OS X.

    I installed Skype correctly, opened it to log in and leave some PLISTs behind and quit it again. This all happened in my Tutorial account, which is an admin account and never failed to serve me.
    [​IMG]
    [​IMG]

    Then I began a search for items using the name "skype" and narrowed it down to only search on my boot volume (Macintosh HD).
    I then included system files and visible and invisible files in the search.

    This is what I got and expected, 13 to 15 files, but with some not having an actual location on the volume or anywhere else.
    I include several screenshots, with each culprit file selected, and as you can see from the Path Bar, there are not anywhere.
    In this screenshot you can see, that the folder "skype.com" actually has a location.

    [​IMG]

    Now it does not have any location, as goes with the rest of the shown files.

    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]
    [​IMG]

    Now I include a screenshot of the Get Info window of the "#skype.com" folder, I thought maybe it had to do with permissions, thus I clicked the lock icon, but no password entry field appears, it just looks like the second screenshot.
    [​IMG][​IMG]

    I can also not drag a file or folder to the Terminal window.

    Double clicking the files or folders results in the Fix Alias / Delete Alias dialog, pressing Delete Alias does not work or result in anything, Fix Alias does not let select me a different folder to fix it to.
    [​IMG]
    I also tried to Fix Alias with a folder I created and named "#skype.com" and stored on the Desktop. It does not work and I only get this error message:
    [​IMG]

    I searched the www using "#skype.com missing location mac os x" and other search terms and have not found a solution, maybe I am missing the correct terms for this behaviour.


    TLTR:
    I am using Mac OS X 10.6.8 and am not able to find the locations of several files and folders I came upon a Finder search including system and invisible files.


    SOLUTION:

    While writing the last bit about aliases, I thought, why not search for aliases and came upon this thread, which linked to this thread and a post of Sarance.

    Anyway, I downloaded the trial of PathFinder and installed it and then ran it. I did a search for items named "skype" and it found those dead aliases and could delete it without problem. Then I emptied the Trash and did a search in Finder again, and nothing was found.

    Thanks for reading.
     
  2. msephton macrumors regular

    msephton

    Joined:
    Jan 6, 2004
    Location:
    Cornwall, UK
    #2
    Thanks for this solution.

    The simple act of searching for the file in Path Finder was enough to clear it in my situation. I guess I could have reindexed Spotlight and saved myself some time?
     

Share This Page