Free 3.0 firmware for iPod touch doesn't work.

Discussion in 'iPod touch' started by theresekathryn, Sep 3, 2009.

Thread Status:
Not open for further replies.
  1. theresekathryn macrumors newbie

    Joined:
    Sep 3, 2009
    #1
    2 days ago I discovered that I could download the 3.0 firmware onto my iPod touch 2G 2.2.1 for free. I was excited to try out apps, such as the new one for facebook.

    I downloaded it, no problem. I shift+clicked update, no problem. My iPod went through the whole process, including the restarting and resyncing, no problem.

    HOWEVER

    When it was all over, I unplugged my iPod and excitedly, had a look. Nothing was different. No spotlight, no landscape keyboard in mail, no copy and paste. I also couldn't download my long sought after 3.0 exclusive apps.

    I have tried updating it several times. Each time it seemed as legit as always, it went through the whole lengthy, tiresome process. But nothing ever changed.

    Why? Please help!
     
  2. RKO macrumors 6502

    RKO

    Joined:
    Oct 21, 2008
    #2
    Issue Solved - it's so easy to get it to work, I don't know what your problem is - all you have to do is purchase via iTunes and you are on your way. Works for me! :rolleyes:
     
  3. theresekathryn thread starter macrumors newbie

    Joined:
    Sep 3, 2009
    #3
    I'm not sure if I'm willing to spend 13$AUD on it..
     
  4. andybno1 macrumors 68040

    andybno1

    Joined:
    Nov 6, 2007
    Location:
    Liverpool, UK
    #4
    go to settings --> general --> about and see what version firmware is installed

    sound like someone did not put the correct software on their iPod
     
  5. yellow Moderator emeritus

    yellow

    Joined:
    Oct 21, 2003
    Location:
    Portland, OR
    #5
    Unfortunately, 3.0 for the iPT is a pay-for app, it is not free.
     
Thread Status:
Not open for further replies.

Share This Page