Free Apps from Apps Store Stopped Working

Discussion in 'iPod touch' started by john445, Jan 8, 2009.

  1. john445 macrumors newbie

    Joined:
    Jan 8, 2009
    #1
    I am a recent iTouch owner. I have downloaded MarbleMash, Labyrinth LE and AOL Radio from the apps store. All three have worked well for about a week. Now when touching either of the three icons to launch I get the opening screen from the the app for about one or two seconds and then back to the main icon screen. None of the three will launch anymore. All the apps that came stock with the iTouch work fine.

    Any thoughts or assistance are appreciated.

    John
     
  2. Pgohlke macrumors 6502

    Joined:
    Jan 9, 2009
    Location:
    Centerville, Ohio
    #2
    Try resetting by holding down home and sleep for 10 seconds. If that doesn't work you might have to delete them and redownload them
     
  3. silentsharky macrumors newbie

    Joined:
    Jan 15, 2009
    #3
    Sync problem

    The exact same thing happened to me and I realized it is because I tried recharging it on another computer which had Itunes on it. When I plugged it back on my own computer and synced it...it worked again...

    If you have a home and work computer sync your applications on both so that both libraries have the same apps that are on your Ipod this way they will work all times...
     
  4. big-blue-wolf macrumors regular

    big-blue-wolf

    Joined:
    Feb 10, 2007
    Location:
    15.8 miles from Molineux
    #4
    You don't necessarily have to completely delete the apps. Try removing them from your iPod first and then reinstall them by resyncing. By removing the apps you have to delete all associated data so when you reinstall, it creates new data for each app which may remove the problem.
     

Share This Page