Free Space Error: OS? SSD? MBP?

Discussion in 'MacBook Pro' started by thatoneguy82, Sep 13, 2012.

  1. thatoneguy82 macrumors 68000

    thatoneguy82

    Joined:
    Jul 23, 2008
    Location:
    Beach Cities, CA
    #1
    So, I've had this problem for a while now. I have a Crucial m4 256GB SSD and it's about 8 months old. Problem is when I delete a large number of files at once or even one big file, the free space would be wrong. Disk Utility usually says something about "orphaned blocks" with a bunch of numbers. It's become almost routine now for me to boot into my Recovery drive every time I delete a lot of data since disk repair is only available there. I really don't know what's causing it. I turned on TRIM via TRIM Enabler and it still persists. Is this a OS problem? I've gone to Lion to ML with same problems. MBP? No idea, this is my first SSD. Or is my SSD faulty? I've tried the reformat thing once before and it still persisted. I emailed Crucial about this and they suggested a power cycle? Anyone know what this is or if it may have the potential to remedy my problem?

    Any ideas?

    Power Cycle Instructions from Crucial
     
  2. sjinsjca, May 19, 2013
    Last edited: May 26, 2013

    sjinsjca macrumors 68000

    sjinsjca

    Joined:
    Oct 30, 2008
    #2
    I went searching for "SSD, orphan" here and found your post.

    I've had the same problem, twice now. In my case the machine is a MBP Retina, December 2012, with Apple's 500GB SSD, fully updated OS X Mountain Lion 10.8.3.

    Symptoms are mainly gradual loss of free space. Today it reported I'd run out of space on my SSD. Doing cmd-I on my disk showed about 30GB free --not enough. Worse, Disk Utility showed only 14MB free!

    I deleted some files, and the situation remained pretty much unchanged. I ran the disk-validation tool in Disk Utility and it found orphan blocks.

    Those can't be repaired while booted on the same disk. So I booted into the Recovery Partition and ran Disk Utility there. (Note you have to unlock your disk if you're using FileVault 2, as I am, if you want the Recovery Partition's Disk Utility to do more than a cursory partition check.)

    A few minutes later, everything had been repaired, and I had more than 100GB free!

    So I'm happy, but wondering: why? Are blocks from deleted files not being reclaimed properly?


    UPDATE: It's happened again. After just a few days since my above post, I checked my hard disk info and it was reporting <50GB free after a few days of usage, in which I created and deleted some large files (virtual machine snapshots, mostly). So I ran Disk Utility again and it reported orphan blocks. So I rebooted into the Recovery Partition, unlocked my disk and ran the Repair function. That corrected the situation, restoring my drive to ~100GB free space.... for now.

    Since this keeps happening, I'll plan on making a trip to the Genius Bar about it. Could be some subtle hardware error, but seems more like an OS X bug.
     

Share This Page