Free VNC app for Snow Leopard

Discussion in 'Mac Apps and Mac App Store' started by macuserfan22, Sep 12, 2009.

  1. macuserfan22 macrumors newbie

    Joined:
    Jul 1, 2007
    #1
    Are there any free vnc apps that work with Snow Leopard? Tried Chicken of the VNC and JollysFast and neither work.

    I know about the Screen Sharing app, but I am having problems connecting to a Tiger computer, so want to try a separate VNC app...
     
  2. nkagemoto macrumors newbie

    Joined:
    Nov 9, 2009
    #2
    Same here.

    I have same problem. I have been used chicken VNC over a year to connect to my office computer. From I upgraded to snow leopard, it does not work. I did try JollysFast too. Is this OS problem? My windows XP uses TightVNC connect no problem.
     
  3. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #3
    I doubt it's an OS issue. I haven't had any VNC issues at all with Snow Leopard. Try opening the Console app and when you go to connect see if any error messages or the like show up that could give a hint to as where the problem is coming from.
     
  4. maflynn Moderator

    maflynn

    Staff Member

    Joined:
    May 3, 2009
    Location:
    Boston
    #4
    What's the problem of chicken of VNC?

    I was just using that on SL earlier this week?
     
  5. joshuawait macrumors newbie

    Joined:
    Feb 21, 2007
    Location:
    San Francisco Bay Area
    #5
    Did you try the Screen Sharing app?

    Did you try the Screen Sharing app? You can find it at

    /System/Library/CoreServices/Screen Sharing.app
     
  6. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #6
    Yes, he did, mentioned it in his first post.
     
  7. dbwie macrumors 6502

    Joined:
    Jun 11, 2007
    Location:
    Albuquerque, NM, USA
    #7
    If you want remote access to (and remote control of) another Mac or PC, from your Snow Leopard Mac, check out LogMeIn.

    https://secure.logmein.com/US/home.aspx

    I use the free version. Works well for my purposes, connecting to a Windows 2000 box. Can also connect to another Mac. They even have an iPhone app.
     
  8. SHADO macrumors 6502a

    SHADO

    Joined:
    Aug 14, 2008
    Location:
    Beach
    #8
    TeamViewer also works well. I use it to troubleshoot friends' computers and I've never had a problem with it.
     
  9. phillph61 macrumors newbie

    Joined:
    Dec 31, 2009
    #9
    CofVNC

    I have recently upgraded to Snow Leopard and Chicken still works, but it doesn't refresh after sitting for a while. It will just close the connection. If you're active in the window it's fine.

    philliph61
     
  10. nullx86 macrumors 6502a

    nullx86

    Joined:
    Jun 26, 2009
    Location:
    Wilmington/Jacksonville, NC
    #10
    I'm running COTVNC with no problems on 10.6.2

    also, you can use the BULIT IN Screen Sharing app.

    just go to vnc://ip.add.ress.here (example vnc://192.168.1.45 or vnc://google.com)
     
  11. Vanthu macrumors newbie

    Joined:
    Aug 30, 2010
    #11
    VineServer

    Install a copy of Vine Server from Source Forge ( http://sourceforge.net/projects/osxvnc/ ) and install it on the Tiger machine. Turn off the OSX file sharing and use Vine Sever as your VNC server. That should solve your connection problems.
     
  12. iggypod macrumors 6502a

    iggypod

    Joined:
    Jun 23, 2010
    #12
    Another Teamviewer vote. It is free.
     
  13. mulo macrumors 68020

    mulo

    Joined:
    Aug 22, 2010
    Location:
    Behind you
    #13
    guys guys guys, VNC is already included in OS X, and it runs MUCH better then chicken of the VNC!

    hit (CMD+K) in finder, then type vnc://ipaddressofserverhere/ and you will be connecting
     
  14. jdiamond macrumors 6502

    Joined:
    Dec 17, 2008
    #14
    No keys in built in viewer, killed the Chicken!

    I tried he built in viewer, and it is MUCH better than Chicken, but it only supports encrypted key strokes. As a result, I cannot use it - the desktop I connect to doesn't support that.

    But - and this is warning - after trying the built in vnc client JUST ONCE, my Chicken has never worked again (except once in a blue moon). It just instantly says authentication failed. Believe me, I've tried everything. If your Chicken works in Snow Leopard, don't try the built in viewer. Now I have nothing and have to use X-Windows for everything.
     
  15. am12 macrumors newbie

    Joined:
    Jun 24, 2009
    #15
    I'm also stuck. I'm also using Snow Leopard (10.6.4) as a client

    I'm trying to use VNC to connect to a Windows Server (Real VNC, VNC Server 4.1.2)

    1- Chicken of the VNC gives me "Server closed the connection"

    2- JollysFastVNC just says "Closed", but in the Console log I get a few errors:

    10-10-21 9:58:52 AM JollysFastVNC[4912] (003664b0.0291)-[NetworkConnection connectWithSettings:] trying: XXXXXXX-HOSTNAME-REMOVED-XXXXXXX
    10-10-21 9:58:52 AM JollysFastVNC[4912] (003664b0.0726)-[NetworkConnection connectToAddress:securityType:] Not using a socks proxy
    10-10-21 9:58:52 AM JollysFastVNC[4912] (008d0a00.1165)-[VNCProtocol authenticate] Caught JNXConnectionException: (008d0a00.0400)-[VNCProtocol authenticate] version read error
    10-10-21 9:58:52 AM JollysFastVNC[4912] (003664b0.0583)-[NetworkConnection disconnect] could not shut down readhandle
    10-10-21 9:58:52 AM JollysFastVNC[4912] (003664b0.0592)-[NetworkConnection disconnect] could not shut down writehandle​

    When I Google "JNXConnectionException" I get NO answers at all.

    3- When I try the built in VNC using "Go -> Connect To Server" I get "Connection Failed", and it tells me to turn on "Screen Sharing" on the server, which is not very helpful given that the server is not a mac.

    Any help or suggestions would be greatly appreciated!

    ----------
    edit: SOLVED.

    Mine turned out to be an IP problem - the VNC server was set to only accept certain IP ranges, which my machine was not inside.
    Glad it turned out to be a simple thing. Jollys works now, though Chicken does not.
     

Share This Page