Frequent Locations issue

Discussion in 'iOS 10' started by JM3581, Sep 15, 2016.

  1. JM3581 macrumors newbie

    Joined:
    Apr 27, 2015
    #1
    Hi I'm hoping someone can help me out with this I updated to iOS 10 on Tuesday by doing a clean install and ever since my frequent locations haven't been working correctly. It seems to be recognizing the towns correctly but the dates are way off like the example below 9/15/16 - 12/31/69. When I click the towns it will show the recorded visits but everyone has 0 visits recorded since (null). The date and time on the phone are correct and I've cleared the locations but the issue comes back as soon as a location is recorded. Any idea how to correct this? Thanks.

    [​IMG]
    [​IMG]
     
  2. christophermn, Sep 20, 2016
    Last edited: Sep 20, 2016

    christophermn macrumors newbie

    Joined:
    Apr 18, 2015
    #2
    I've got a problem with Frequent Locations as well, with iOS 10. They stopped working about a week ago, even though I've been all over town, no locations are ever listed.

    I've tried the usual suspects like resetting network settings, all settings, rebooting phone, disabling then re enabling frequent locations, resetting the history, etc. Nothing works; my frequent locations just doesn't populate or function.

    I've since gotten an iPhone 7 and did an iTunes restore to the new phone and it also has the same issue, so I suspect it's something with the config of my phone's specific software install.

    I don't want to do a fresh iOS install since all of my health/activity data from Apple Watch for the past 18 months will be lost. There doesn't appear to be a way to back that up and selectively restore to a new iOS install.

    Have you had any luck resetting frequent locations?
     
  3. high3r macrumors member

    Joined:
    Jul 23, 2015
    Location:
    Hungary
    #3
    Have you tried 'Reset Location and Privacy'? I had the same (null) entries a few weeks ago and I guess that fixed it. Now I have it on my iPhone 7 again (set up as new) so seems I gotta reset that setting too. :)
     
  4. christophermn macrumors newbie

    Joined:
    Apr 18, 2015
    #4
    Thanks for the tip. I've tried so many things including resetting all settings, resetting location settings, restoring again from backup, disabling location services and reenabling, etc etc. I also updated to iOS 10.0.2. I checked today and now things seem to be working again. It's impossible to say what exact combination of actions fixed things, but I'm hoping it's as simple as a bug that was addressed in iOS 10.0.2 but not mentioned in release notes (as we know well, the published release notes are often just a subset of all actual changes).

    I hope others that had this problem are also back up and working. :)
     
  5. JM3581 thread starter macrumors newbie

    Joined:
    Apr 27, 2015
    #5
    Upgrading to 10.0.2. seems to have fixed the issue for me as well.
     

Share This Page