Frequent Locations not working

Discussion in 'iOS 10' started by Jumpie, Sep 30, 2016.

  1. Jumpie macrumors 6502a

    Jumpie

    Joined:
    Jul 7, 2008
    Location:
    Atlanta
    #1
    I'm not sure if this goes here or in iPhones, but I've had my 7 Plus for two weeks now and no frequent locations have been stored. Nada. Nothing. Zip. Zilch. I've tried turning off frequent locations, deleted the history, everything.

    Anyone have any ideas?
     
  2. 0014 macrumors 6502

    Joined:
    May 23, 2016
    Location:
    United Kingdom
    #2
    I am having the same issue with my iPhone 7 Plus and I've had it since 19 Sept.
     
  3. Jumpie thread starter macrumors 6502a

    Jumpie

    Joined:
    Jul 7, 2008
    Location:
    Atlanta
    #3
    Yep. iPad on iOS 10 works fine. but not on the 7 Plus.
     
  4. 0014 macrumors 6502

    Joined:
    May 23, 2016
    Location:
    United Kingdom
    #4
    I have been on to apple support and this is now escalated three levels up with a senior software engineer. I've spent nearly 3hrs on the phone to him today going through everything I've done and sending screenshots.

    He said it's extremely unlikely to be a hardware issue as the navigation works fine. He thinks there must be an iCloud issue but it's going to take a couple of days to dig in to.

    He asked me to try logging out and back in to iCloud to see if it helped. It has but it put the same info on as the iPad so the dates are showing from 1/1/1970. Which he said pretty much shows it's iCloud related.

    I will keep this thread up to date as and when I get info. But he did say it will take a few days.
     
  5. 0014 macrumors 6502

    Joined:
    May 23, 2016
    Location:
    United Kingdom
    #5
    Seems we are getting somewhere as I now have locations showing on my phone.

    However for my home location it shows this:

    [​IMG]

    Anyone any idea why that would happen? I've checked my address in the contact card and it is correct.
     
  6. Jumpie thread starter macrumors 6502a

    Jumpie

    Joined:
    Jul 7, 2008
    Location:
    Atlanta
    #6
    I don't even have this. My iPad is correct. My iPhone has absolutely nothing.
     
  7. 0014 macrumors 6502

    Joined:
    May 23, 2016
    Location:
    United Kingdom
    #7
    It appears the problem is something to do with iCloud. I am still waiting on a full explanation. But all is working perfectly with the locations and i even got a parked car notification today.
     
  8. 0014 macrumors 6502

    Joined:
    May 23, 2016
    Location:
    United Kingdom
    #8
    You may need to do a clean install with no restore from backup.
     
  9. Jumpie thread starter macrumors 6502a

    Jumpie

    Joined:
    Jul 7, 2008
    Location:
    Atlanta
    #9
    I turned off iCloud and turned back on. So we'll see. I do get parking notifications. But there's a fat chance I'm going to do a clean install. I hate resetting everything up just the way I have it. I just can't believe it works on my other iPhones and iPad. Unreal.
     
  10. thebro20 macrumors regular

    Joined:
    Sep 7, 2014
    #10
    same issue for me here too, iPhone 6s iOS 10.0.2
     
  11. 0014 macrumors 6502

    Joined:
    May 23, 2016
    Location:
    United Kingdom
    #11
    Turning iCloud off and on didn't work for me. Neither did a clean install.

    It's only since complaining to apple that something has been done. But they did say that I would have had to do a clean install anyway as a troubleshooting step.

    It was explained to me that if you keep restoring from a backup each time you get a new phone that it can on rare occasions cause an issue like mine. But they are rare, although reading on here and google there are some with the same problem.

    The guy gave me a quick earlier to say it should now be fixed and that the issue was to do with the restores causing a problem with my iCloud. I must have had something corrupted at some point and when I restored the backup from my 6 plus to my 7 Plus it brought the corruption with it.

    Now that it's working I have bit the bullet and deleted all backups of my phone and currently doing one now. Hopefully nothing else goes awry.

    I did offer that backups should be compartmentalised so like now I could restore all my health and workout data from the last 2yrs. Rather than lose it like I have done.
     

Share This Page