iPod touch Fresh 4.2.1 restore, cydia cant install apps

Discussion in 'Jailbreaks and iOS Hacks' started by Sandbird, Sep 18, 2013.

  1. Sandbird macrumors newbie

    Joined:
    Apr 15, 2013
    #1
    I just formated (5 times so far) my old ipod touch 2g MB version to 4.2.1.
    I opened Cydia and it upgraded itself. After the reboot i tried to download SBSettings but it says it depends on IOS Firmware >=3.0 plus some other dependencies....
    This happens to almost anything i am trying to install...So far only OpenSSH was installed with no problem.
    I restored 5 times and tried jb the device with greenpoison, redsnow and snowbreeze...all ending to the same result.
    My Cydia version is 1.1.6

    Any help would be appreciated
     
  2. darricksailo macrumors 601

    darricksailo

    Joined:
    Dec 18, 2012
    #2
    I think the the dependencies required require a OS running higher than 4.2.1 so that's why you can't install any of the tweaks

    That's also one of the reason why I'm leaving my 2nd gen itouch on 4.1 as is. Since you can only install the latest version via cydia, it's hard for older devices to keep up with them
     
  3. Sandbird thread starter macrumors newbie

    Joined:
    Apr 15, 2013
    #3
    I solved it by custom installing old sbsettings and its dependencies. After that i disabled update notifications in cydia for sbsettings / sbtoggles and airtoggle.
    After that i could install anything :)
    Thanks
     

Share This Page