Fresh install Yosemite corruption error on Mid-2009 MBP

Discussion in 'MacBook Pro' started by HawkinsJS, Feb 1, 2015.

  1. HawkinsJS macrumors newbie

    Joined:
    Feb 1, 2015
    #1
    Today I put an SSD, 8GB of RAM and a new battery in my mid-2009 MBP. All components have installed succesfully.

    I've put the Yosemite Installer on an external HDD, and it boots up just fine on the fresh SSD, but once the installer hits '1 second remaining' it shows up with the error message 'This copy of the install OS X Yosemite application can't be verified. It may have been corrupted or tampered with during downloading'.

    I've changed the date/time via Terminal, but it's still coming up with this error every time I try.
     
  2. Wreckus macrumors 6502a

    Wreckus

    Joined:
    Jan 22, 2015
    Location:
    Edmonton, Alberta, Canada
    #2
    Only reason for this that I can think of is that the usb drive that you installed Yosemite from is corrupt or damaged. I would try restarting the mac and try the installation again. If that doesn't work, If you can, I would re-download the yosemite installer on the USB and re-install again.
     
  3. simonsi macrumors 601

    simonsi

    Joined:
    Jan 3, 2014
    Location:
    Auckland
    #3
    Did you get the installer file direct from Apple or torrented?
     
  4. Gjwilly macrumors 68030

    Joined:
    May 1, 2011
    Location:
    SF Bay Area
    #4
    I had this same thing with a Mac Mini and what finally worked was putting the RAM back to 4GB.
    I bought the machine used and it came with Mavericks and 8GB and it ran fine for months but every time I tried installing Yosemite it would crash.
    I downloaded the installer multiple times and even on multiple computers and the install would always fail.
    I even made a USB installer and it would fail.
    I finally found a thread somewhere where someone suggested putting the RAM back to the stock configuration so I tried removing one of the RAM sticks reducing it to 4GB and the install finally completed successfully.
    And after the install I was able to put back the second stick making 8GB again.
     
  5. poiihy macrumors 68020

    poiihy

    Joined:
    Aug 22, 2014
    #5
    Speaking of RAM, you should always do a thorough test with Memtest86 when you install new RAM. Maybe that has something to do with it.
     

Share This Page