Friend has an odd bug

Discussion in 'iPhone' started by Reevey, Oct 25, 2011.

  1. Reevey macrumors newbie

    Joined:
    Mar 25, 2011
    #1
    My mate's come to me screaming about his new iPhone 4S. It's got, from what I've seen briefly, an odd bug related to volume.

    Basically, the volume control has disappeared from the apps we've tried, along with the buttons on the side no longer changing.

    I've got some (poor) photos of this (I was in a real rush)

    http://excitedesign.net/iphone/photo-1.jpg
    http://excitedesign.net/iphone/photo-2.jpg
    http://excitedesign.net/iphone/photo-3.jpg

    It comes and goes. Plugging in headphones returns the bar for a bit, but it'll go again at some point. (tried turning it off and on again :cool:)

    [disclaimer] He's highlighted the problem, I've only seen it really briefly. Not had the chance to check much.[/disclaimer]
     
  2. ste1164 macrumors 6502a

    ste1164

    Joined:
    Jan 4, 2009
    #2
    Id say try to restore it see if that helps. If not take it to an apple store. Seems more of a software bug though.
     
  3. Reevey thread starter macrumors newbie

    Joined:
    Mar 25, 2011
    #3
    Yeah, my initial response to restore it, but was hoping to solve it without having to
     
  4. Lee Adama macrumors regular

    Lee Adama

    Joined:
    Jul 28, 2011
    Location:
    California
    #4
    Try hard reset:
    Press and hold sleep and home buttons till the white Apple logo appears.

    I've had similar issues where my AirPlay icon disappears from time to time.
     
  5. darrinS macrumors regular

    Joined:
    Oct 21, 2011
    #5
    I had a similar problem with my new iPhone 4S. My volume would go in and out just as you describe. It turned out the phone thought it was plugged into a dock. Try this, pull up the multitasking bar and swipe over to the left twice, where you see the volume bar. Click on the arrow which will allow you to send audio etc. to an apple tv. Only options I had were the dock or apple tv, no option for phone.

    I went to the apple store and they gave me a replacement immediately. They didn't even try to reboot or anything.

    Oh and related I'm sure, I couldn't shut down the phone. I would power off but since it thought it was on a dock it would power back up seconds later.
     
  6. FreakinEurekan macrumors 68040

    FreakinEurekan

    Joined:
    Sep 8, 2011
    Location:
    Eureka Springs, Arkansas
    #6
    Related to darrinaltman's post - I've encountered the same thing with my iPhone 4. Appeared to be some "crud" on the dock connector, I carefully wiped the contacts with a wooden toothpick and the problem went away.
     

Share This Page