Friendly warning to people trying El Capitan

Discussion in 'OS X El Capitan (10.11)' started by Quu, Jul 12, 2015.

  1. Quu macrumors 68030

    Quu

    Joined:
    Apr 2, 2007
    #1
    (TL;DR at the bottom)

    Today I tried to revert from the Public Beta back to Yosemite on my 2015 15" rMBP, the one in my signature.

    I did so by using Time Machine as I use that for backups. However I made a critical error, I did not stop El Capitan from backing up to that same Time Machine backup that I had previous backups of Yosemite on.

    When I attempted to restore to Yosemite today using those backups it did not work correctly. It shows me many different backups going back all the normal days as you'd expect and it lists the OS X versions on some of them as El Capitan (the newest backups) and Yosemite (the older ones).

    I naturally selected the Yosemite entries but because El Capitan had already backed up to the same Time Machine volume. it had altered all of the file indexes, making it incompatible with Yosemite.

    When I restored and logged in, about 50% of my files were not present. My iTunes library, documents, many folders, application settings etc were all gone.

    I restored it two more times, once from recovery mode (CMD+R on bootup) and once from Migration Assistant and both resulted in the same problem.

    I also tried to open Time Machine in yosemite using the normal Time Machine interface to just recover what I could manually but Yosemite is completely unable to read any of the backup entries in Time Machine, the format is just not compatible.

    So finally I rebooted to recovery mode and restored back to El Capitan and all my files were present back as they were originally. The moral of the story, don't be stupid like me and allow your beta of El Capitan to mess with your Yosemite backups, start a new backup instead.

    TL;DR: El Capitan changed my Time Machine format making reversion to Yosemite impossible without file loss. Start a new backup for El Capitan while testing it instead of using your previous Time Machine backup volume.
     
  2. Zerroz16pro macrumors newbie

    Joined:
    Jul 12, 2015
    #2
    Im in PB1 also on my MBP 13" 2015 and no major bugs so far. It is fast compare to Yosemite beta before. I always had dedicated xternal hardrive for my time machine backup and never ever use it for el capitan so it will not automatically alter my yosemite backup.
     
  3. jlrcmba14 macrumors newbie

    Joined:
    Aug 28, 2014
    #3
    I've had similar issues, so I went back to 10.11 and now it just won't back up at all and sees my Time Machine drive as apparently empty (400 GB drive, says 408GB available) but also says I have a backup from prior to the restore. It just sticks on preparing... for days on end when I try to back up. All I see when I navigate to the drive is the sparsebundle.
     
  4. KALLT macrumors 601

    Joined:
    Sep 23, 2008
    #4
    I have two Time Machine backups, one with an external drive and one with a Time Capsule (actually a Raspberry Pi with the netatalk software). When I upgraded, I received the notification that my latter backup was not compatible and needed to be recreated. Could it be that Apple has upgraded the Time Machine software as well, leading to some incompatibilities? My external drive backup is still working fine, I think.
     
  5. Quu thread starter macrumors 68030

    Quu

    Joined:
    Apr 2, 2007
    #5
    Yes I think it's very likely that El Capitan has changed the format. It appears to be incompatible with earlier versions.
     
  6. melb00m macrumors regular

    Joined:
    Feb 4, 2011
    #6
    You should be able to revert to a clean install of Yosemite and copy all the relevant files from the backup yourself.
    However, you'll definitely need to re-configure the system yourself.
     
  7. Quu thread starter macrumors 68030

    Quu

    Joined:
    Apr 2, 2007
    #7
    I already tried this. Yosemite was completely unable to access the files inside the sparse bundle. Like literally even mounting it manually in the finder the folders were viewable but the files were gone. In El Capitan, mounting the sparse bundle manually in the finder makes all the files fully accessible.

    El Capitan seems to completely alter the file table.
     
  8. Taz Mangus, Jul 20, 2015
    Last edited: Jul 20, 2015

    Taz Mangus macrumors 68040

    Taz Mangus

    Joined:
    Mar 10, 2011
    #8
    Maybe what you are experiencing has to do with permissions on the sparse bundle. In Yosemite, open the terminal application:
    • In finder, browse to where the sparse bundle resides.
    • In the terminal app enter: cd <drag with mouse sparse bundle from finder to here>
    • In the terminal app enter: ls -l

    Now look at what the "ls" command has reported. You should see your user account name for the ownership. If you see numbers then ownership is the problem:
    • In the terminal app enter: chown <your user shortname> *

    Now try to mount the sparse bundle. I had this happen not too long ago (not related to what happen to you) and changing the ownership in the bundle fixed the issue where I could to mount the sparse bundle.

    By the way how many user accounts did you have on the Yosemite install and the El Capitan install?
     
  9. Quu thread starter macrumors 68030

    Quu

    Joined:
    Apr 2, 2007
    #9
    I'm just gonna stick with El Capitan. Should be going final in like what two months? I can stomach the few minor bugs I have until then.

    I only have one user account on both Yosemite and El Capitan. Both identical since I used the restore from Time Machine feature.
     
  10. ToddJ macrumors 6502

    Joined:
    May 23, 2008
    #10
    did it come up with errors when you restored it to Yosemite? if not, how did you know that stuff was missing? I just wondering because i have a kinda similar problem..
     
  11. Fishrrman macrumors G5

    Fishrrman

    Joined:
    Feb 20, 2009
    #11
    My advice to ANYONE contemplating experimentation with the El Capitan betas:

    DO NOT trust Time Machine to back up your previous OS before trying El Capitan.

    Create a BOOTABLE CLONED BACKUP instead, using either CarbonCopyCloner or SuperDuper. Even if you don't currently use CCC, it's free to download and free to use for 30 days, so the cloned backup will cost you nothing.

    This will make it far easier (trivial, as a matter of fact) to "get back to where you once belonged" with your previous OS, in the event that El Capitan doesn't work out for you.

    My opinion only.
    Others will disagree.
    Some will disagree vehemently.
     
  12. Quu thread starter macrumors 68030

    Quu

    Joined:
    Apr 2, 2007
    #12
    I opened iTunes and half my music was gone. That's when I noticed what had occurred, then I checked my disk and 100GB of files were not there.
     
  13. nbnbxdnb macrumors regular

    Joined:
    Sep 1, 2010
    #13
    I think the moral of this story is, do not use the backup disk for Yosemite in El Capitan beta. It wouldn't be a problem once 10.11 is officially ready. But at this state, it is better to use a new disk for time machine in 10.11.
     
  14. ToddJ macrumors 6502

    Joined:
    May 23, 2008
    #14
    After a LONG ordeal i finally got El Capitan and my iMac back up and running. I also restored it from a time machine backup. However, I ALSO have stuff MISSING ....around 45 gbs to be exact.....not sure what is gone...argh!
     

Share This Page