Front camera shutter won't open after iOS 5

Discussion in 'iOS 5 and earlier' started by Pestana, Oct 15, 2011.

  1. Pestana macrumors newbie

    Joined:
    Oct 15, 2011
    #1
    Hello,

    I upgraded my iphone 4 to iOS 5 and since then i can't use my front camera as the app freezes if i do so. I can perfectly use the main camera but when i try to switch to the front camera the app freezes, then i try to go to the main camera again but i can't and the only way to have at least the main one working is to restore to factory default.

    It seems like a software problem, both cameras were working perfectly before the update...

    I tried:

    - Simple Reset ( holding the on/off button and the home button at the same time )
    - Restore from backup via iTunes
    - Restore to factory default

    Anyone had this problem? Any ideas on how to solve this?

    Best Regards
     
  2. Matthew Yohe macrumors 68020

    Joined:
    Oct 12, 2006
  3. Pestana thread starter macrumors newbie

    Joined:
    Oct 15, 2011
    #3
    Never.
     
  4. Patata macrumors newbie

    Joined:
    Oct 29, 2011
    #4
    Same problem with front camera after iOS 5

    I have the same problem. After updating iOS5, front camera does not work at all with native camera.

    If I use other applications such as Camera Genius, rear camera can be used, but front camera is in black.

    Native camera seems stuck in front camera, can't be changed to rear or video. Sometimes I get obturation image, others black screen but I can't get out of there.

    I have tried same things as Pestana, but no luck. Never jailbroken either.
     
  5. A Cellular Edge macrumors newbie

    Joined:
    Nov 2, 2011
    #5
    Same here

    I have a 4g that was updated to ios 5 and have the exact same issue. I replaced both the front and rear camera and have the same problem. However when I swapped motherboards everything works fine. I even updated the 2nd motherboard to ios 5 and everything worked. The update had to have done something to the original motherboard. I restored the original motherboard a second time and it worked, but once you click on the front facing camera its game over. If anyone figures this out please post a fix. Thanks.
     

Share This Page