Front Row for Lion (with Arabic!)

AnonMac50

macrumors 68000
Original poster
Mar 24, 2010
1,523
300
Finally Lion has been released, and the NDA lifted, and I can now finally provide a package I made for Lion that installs Front Row. I used the files from the ABMME package for OS X (it installs an Arabic language pack for Snow Leopard, and you can download it from their site). I combined files from that and ones from normal Snow Leopard to provide Front Row for Lion. If I find any more localization packs I'll update the package to support that. Please direct me to any localization packs you can find. This fits in with Apple's idea of many language support in Lion. Enjoy, and tell me what you think.


http://cl.ly/0E3i0X271u34392U3v42
 

PeterHolbrook

macrumors 6502a
Sep 23, 2009
988
119
Finally Lion has been released, and the NDA lifted, and I can now finally provide a package I made for Lion that installs Front Row. I used the files from the ABMME package for OS X (it installs an Arabic language pack for Snow Leopard, and you can download it from their site). I combined files from that and ones from normal Snow Leopard to provide Front Row for Lion. If I find any more localization packs I'll update the package to support that. Please direct me to any localization packs you can find. This fits in with Apple's idea of many language support in Lion. Enjoy, and tell me what you think.


http://cl.ly/0E3i0X271u34392U3v42
Can you clarify if this version of Front Row is higher than 2.2.1 or if the internal links to iTunes have been somehow modified to make it compatible with the latest xml structure? Thanks.

PS I answer myself: No, it isn't compatible with the latest iTunes (10.4) xml structure. Is it feasible to somehow modify Front Row internal links to iTunes to make it compatible again?
 
Last edited:
Comment

AnonMac50

macrumors 68000
Original poster
Mar 24, 2010
1,523
300
Wait, what?

I don't know if it might be possible to fix it (I'll try), but does it also break it on Snow Leopard?

EDIT:
Back in Leopard's time, they released Front Row 2.1.7 that supports iTunes 8.1. I'm guessing that there might be an update for Snow Leopard in the coming days. I don't think they'd leave out Front Row for Snow Leopard, and make it pretty much useless. I'll update my package should Front Row be updated.

AnonMac50
EDIT 2:

What version of the iTunes Library does iTunes 10.4 use?
 
Last edited:
Comment

AnonMac50

macrumors 68000
Original poster
Mar 24, 2010
1,523
300
I am working on finding the iTunes Library version or converting it or something, but meanwhile, I am waiting for Apple's update to Front Row, if there will ever be one.

AnonMac50
 
Comment

AnonMac50

macrumors 68000
Original poster
Mar 24, 2010
1,523
300
Believe it or not, iTunes 10.4 on Snow Leopard with Front Row, and Front Row still functions. What's going on?
 
Comment

AnonMac50

macrumors 68000
Original poster
Mar 24, 2010
1,523
300
Check this hint out:

http://hints.macworld.com/article.php?story=20110915094018524

However, for Front Row for with the previous way (if you don't like iTunes Library Sharing for example) I think it is because it is 64-bit, not 32-bit, it might have some sort of different library version or way of using the file. For example, Front Row works in Leopard and Snow Leopard with iTunes 10.4, but it doesn't with Lion. This is probably for that reason, but this is just a guess.
 
Comment

brownjd

macrumors newbie
Oct 18, 2011
1
0
Can anyone confirm if Front Row works with Snow Leopard 10.6.8 and iTunes 10.5?

If so, can someone post up the support files so we can try it with Lion?
 
Comment

AnonMac50

macrumors 68000
Original poster
Mar 24, 2010
1,523
300
Can anyone confirm if Front Row works with Snow Leopard 10.6.8 and iTunes 10.5?

If so, can someone post up the support files so we can try it with Lion?
It works.

Which support files do you want?

PS What happens if you start iTunes 32-bit and rebuild your iTunes database in Lion?
 
Comment
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.