Front USB ports not working.

Discussion in 'Mac Pro' started by fawkmee, Dec 12, 2011.

  1. fawkmee macrumors newbie

    Joined:
    Oct 10, 2011
    #1
    Hi.

    The front USB ports on my 2008 Mac Pro have stopped working. I've read that its a common problem but a quick search did not lead to any real definitive answers that helped with my problems.

    The three ports on the back work fine. Its just the two up front thats giving me problems. I've tried different cables, different devices (mice, keyboards, etc), etc.. and nothing works in the front.

    I've also tried the various reset procedures (PRAM, SMC, etc) recommended by apple and very old threads with no luck. I've read somewhere that there could be loose cable connecting to the logic board. I'm by no means tech savvy so I wouldnt know what to look for to fix that.. Does anyone know where such a loose connection could be? Any pics? I don't want to go in there blindly and mess it up even more.

    One thing I noticed with the front usb ports: I have a card reader with a led light that turns on when its plugged in. This light turns on for a split second then dies when plugged in to either port. So the ports are not completely dead.. right?

    Thanks in advance for the help.
     
  2. eljanitor macrumors 6502

    eljanitor

    Joined:
    Feb 10, 2011
    #2
    Could be the logic board, the Power button assembly, or the cable that connects that to the MLB.

    Happy diagnosing!
     
  3. wrinkster22 macrumors 68030

    wrinkster22

    Joined:
    Jun 11, 2011
    Location:
    Toronto
    #3
    Unfortunatley USB ports are part of the Logic/Motherboard and broken Ports likely require a full replacement of the board which can cost anywhere from 0$ to 900+$. It is possible that the cable attaching the ports is loose or broken.
     
  4. 666sheep macrumors 68040

    666sheep

    Joined:
    Dec 7, 2009
    Location:
    Poland
    #4
    Front ones aren't. They're on separate board, connected to logic board with cable. Part number 922-8491 (for 3.1 ofc).
     
  5. wrinkster22 macrumors 68030

    wrinkster22

    Joined:
    Jun 11, 2011
    Location:
    Toronto
    #5
    Thats good for the OP! a cheaper repair is nice :)
     
  6. fawkmee thread starter macrumors newbie

    Joined:
    Oct 10, 2011
    #6
    Thanks for the replies. So the general consensus is that the front ports on my Mac Pro are fried? Will replacing that part be fairly straight forward? ie. undoing a few screws here and there after taking out the fan assembly? I haven't ran into any tutorials about changing that out..
     
  7. chope07 macrumors newbie

    Joined:
    Jan 25, 2012
    #7
    I've landed in this thread because I have the same problem, because I tripped over my front connected USB wire last night, but only the top single USB port on the front is not functioning, I fear maybe physically damaged from the dislodging of the cable.

    How much am I looking at just to have the one USB port fixed?
     
  8. ActionableMango macrumors 604

    ActionableMango

    Joined:
    Sep 21, 2010
    #8
    Open it up and use a good flashlight to look at the USB connector's connections to it's little board. With any luck, you've simply cracked one of those connections and can resolder it for free.
     
  9. martinm0 macrumors 6502a

    Joined:
    Feb 27, 2010
    #9
    I'd say get a powered USB hub and call it a day. Sure, its nice to fix the machine, but the cost will most likely be more than just grabbing a hub.

    On the flip side, like others have said, check in the case and see if the cabling is loose. I expect that with the single port not working you tweaked the circuit board or port and damaged it though. Oh well, could have been a lot worse.
     
  10. highdefw macrumors 6502

    Joined:
    Apr 19, 2009
    #10
    Had to get my front board panel replaced last summer, cost about $150 :(
     
  11. alphaod macrumors Core

    alphaod

    Joined:
    Feb 9, 2008
    Location:
    NYC
    #11
    The front ports are very easy to replace. It might require some disassembly of your computer, but otherwise it's removing a few screws, unplugging the old from the motherboard, plug in the new kit, and put your computer back together. I think I spent 10-15 minutes on it…

    Not sure how much it was for the part because I got the part under warranty.
     
  12. chukyx007 macrumors newbie

    chukyx007

    Joined:
    Jan 29, 2012
    #12
    Hi

    Pretty sure this is not too relevant to this post, but am trying to find the closest relevant one. I have an imac, usb ports work fine with everything, computer works fine (am running Mac os 10.4 "Tiger") but my sandisk u3 usb smart drive will not come up...ANYWHERE!!! the drive works fine (smart drive that is) it just refuses to come up on my mac, anywhere! It does not come up on the desktop, finder, u3 loader utility or whatever, tried to remove the password tried alt+option+p+r when boot up, it will not READ.
    -Chucky
     

Share This Page