frozen throne won't start

Discussion in 'Mac and PC Games' started by beloved84, Apr 24, 2007.

  1. beloved84 macrumors regular

    Jun 1, 2006
    when i install WC3 only it works, but when i install frozen throne the game wont start. The little icon on the dashboard switches from frozen throne to wc3 then back to frozen throne and then disappear. Have any idea how to fix this?
  2. AoWolf macrumors 6502a


    Nov 17, 2003
    Daytona Beach
    everything is patched up?
  3. GoinBerZerKeLey macrumors newbie

    Sep 16, 2007
    Same problem

    Just switched to Mac from PC. Going to college soon and I want to play dota, please help. I have the same problem... :confused:

    No idea how to get (the right) patch, keep downloading patches that are useless to me because I don't know what to do or how to install them...
  4. GoinBerZerKeLey macrumors newbie

    Sep 16, 2007
    I'll answer my own question... but there's more!

    Installed Reign of Chaos then installed Frozen Throne into a new folder. Game played but battle net is acting like a bitch "Invalid patch" ?! Argh, it automatically downloaded v1.21 but it doesn't recognize that it did.

  5. nutman macrumors regular

    May 19, 2006
    You need to install both roc and ft before patching the game. the ub patch changes the way the files are organized.
  6. Tanner24 macrumors newbie

    Oct 9, 2007
    Ya i am having the same problem, i know its not a problem with graphics or anything because my comp plays WoW well. I have tried deleting divx, and changed the movie file too moovies, i heard that thatwould fix it but it didnt, and help would be really nice.
  7. gamerz macrumors 6502


    Oct 2, 2006
    Same problem here... I installed WC3 Reign of Chaos, that worked fine, moved on to TFT, DIDNT finish the battle net download, mabye thats my problem. Anyways, I dont play, quit the game.

    Insert TFT disc, and it says i need to install it again.

  8. Sdashiki macrumors 68040


    Aug 11, 2005
    Behind the lens
    Install RoC, dont open it.

    Install FT, open it and attempt to sign onto Bnet.

    That will patch it all I believe.

Share This Page