Frozen trackpad and keyboard

hellfried

macrumors member
Original poster
May 3, 2008
76
3
Penang, Malaysia
I have a 2019 13" MBP (2 thunderbolt ports). A few months ago I started running into the issue of frozen trackpad and keyboard after waking the computer up from sleep. The whole screen is frozen but the touch bar still functions. It can take upto 20 seconds before the computer starts to work again.

I noticed that this issue doesn't arise when I am using the laptop at home. The only difference between work and home is that the wifi connection in my office is very spotty and erratic which makes me think that it is something to do with the wifi. I have tried everything. Messing with the settings for the trackpad, disconnecting and forgetting any blue tooth devices that were connected in the past, turning off the screen saver etc. Nothing works. It is quite embarrassing for a machine that costs a fair amount of change.

Can anyone shed some light on this highly irritating issue?
 

DarkMCS

macrumors member
Jan 25, 2008
48
22
Same for both my 2019 and 2020 MBP 13.3 (both with 8th gen i5), and only at work with sloppy wifi/internet
 

notrealme

macrumors newbie
Jan 18, 2020
2
0
Same here on my 2019 15inch MBP.
When I just leave it after certain period of time(depends on system settings) it goes to sleep mode. And when I wake it up - keyboard and track not responding sometimes not too long but another time it can take up to minute or more. This is sooo annoying and makes me mad. 😡 When bluetooth is ON is this scenario its even worse and can take much longer. Plus there is popup shows up regarding connection of external bluetooth keyboard which I don`t and never used!

I tried to search over internet, but all the solutions so far doesn`t make any difference. Like resetting SMC, NVRAM, trackpad/power saving settings. Also ran a bunch of system/hardware diagnostics - Zero issues! I even had to dig into system files for trackpad, keyboard and related to power management/saving around this area in hope to find something related and maybe make some changes. But couldn`t find anything. Also checked pmset command line utility for possible options, but also no luck and nothing related. I visited that stupid 'genius' bar in January, but it was useless, just wasted my time.

Hope maybe somebody, who has had this problem and found solid solution(preferably tech savvy/power user), will chime in and give some hint what to do.
 

Similar threads

Register on MacRumors! This sidebar will go away, and you'll see fewer ads.