Become a MacRumors Supporter for $25/year with no ads, private forums, and more!


macrumors 6502
Original poster
Nov 5, 2008
Paris, France
Whenever I plug my external usb hardrive (partionned both for storage and time machine), a process (fseventsd) uses 100% of the cpu hand makes all other apps hang and/or crash. I can't repair the external hardrive because disk utility becomes unresponsive. I tried to let fseventsd do its thing for 12+ hours thinking it woud stop but it didn't.
I searched the web for an answer to this question but I found no fix.
Please help!

P.S. Please move this thread to the Mac OS X forum


macrumors 68020
Feb 8, 2008
I know you had this issue very long ago, but I can attest to the fact that this issue is STILL present in the latest Mac OSX (10.7.2). In my case, it's on a remote drive.

The issue is caused by Time Machine and from what I can tell, is due to a corrupt backup/backup drive. I'm presently running disk utility on the drive so see if there are any errors.

For those of you coming from a search result, the easiest way to fix this is to disable Time Machine and restart the computer (you may have to manually power the machine off if it won't shut down). I'll edit this post when I get it fixed for sure, but you may have to erase the backup to get it fixed.


macrumors 68020
Feb 8, 2008
I found a solution! (from here)

The drive being mounted is being improperly used by fseventsd. To make it stop, (in Terminal) make a directory called ".fseventsd" (mkdir .fseventsd) and add a file inside called "no_log" (touch no_log). The second I did these commands the excessive CPU usage stopped and Time Machine worked as normal!

My time machine backups are being done from my MBP through iCloud to my Mac Mini with Lion Server hosting a Time Machine share.


A better solution is to just delete the backup sparsebundle for the machine having the issue.
Last edited:


macrumors newbie
Mar 22, 2013
Thanx for this Posting.
I have this Problem too.

But – i have it on two machines, where TimeMachine is disabled since i used them the first Time (i deactivate TM as one of the first Things during first System Configuration).

And – mysterious – today i have this Problem on two Machines (Mac Pro 2011 and MacMini 2012) at the same Time. So it looks there could be a Connection.

Any Ideas what the Problem is and what i can do?

Thanx a lot (and please sorry for my cruel English)
Register on MacRumors! This sidebar will go away, and you'll see fewer ads.