ftp help

Discussion in 'Web Design and Development' started by kevin08, Nov 10, 2008.

  1. kevin08 macrumors newbie

    Joined:
    Nov 10, 2008
    #1
    i am using fetch to upload websites. Have been using for some time. after changing ISP have trouble uploading my websites , i get a message, software caused connection abort. Maybe i have fiddled with settings a bit not sure what i am doing.
    any help appreciated
    tried cyberduck got same response
     
  2. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #2
    Have you checked with your new ISP? They may block certain types of connections, though it's unusual to block port 21, which is used for FTP. There could also potentially be a proxy that you need to negotiate. Essentially, I can only guess because I don't know who your ISP is and don't know what settings you're using in your programs.
     
  3. kevin08 thread starter macrumors newbie

    Joined:
    Nov 10, 2008
    #3
    FTP trouble

    Thanks, my ISP is AA.net and they say it must be something wrong with program (Fetch) or maybe i changed settings. They say they don't block websites. I have tried cyberduck same response. no go.
    In System preferences i am not sure what should be ticked for web sharing and all those settings.
    It was all working when i was with optus but since i change it stopped. the i fiddled with system preferences and made a mess of things.
    thanks for your reply. appreciated
     
  4. MojoWill macrumors 6502

    Joined:
    Jun 13, 2008
    #5
    try changing your FTP program (fetch or cyberduck) to passive FTP
     
  5. freewardeluxe macrumors newbie

    Joined:
    Nov 10, 2008
    #6
    FTP Idea!

    I guess you have to talk to your ISP regarding this, as some of they block that kind of services/ports. Or for business point of view, its another service that you have to pay to them :)
     
  6. TheKnifeFight macrumors member

    Joined:
    Oct 29, 2008
    Location:
    Socal
  7. kevin08 thread starter macrumors newbie

    Joined:
    Nov 10, 2008
    #8
    ftp problem

    Using my imac 15 months old.
    can anyone tell me what i should have ticked or un-ticked in system preferences, in the sharing...firewall and internet.
    i think this where i am going wrong for uploading using my ftp program fetch, t was all working until i changed isp to aa.net.
    help !!!!!! i need to upload my websites. i can upload using webftp but takes a while and is fiddly
    thanks all
    ISP say they don't lock any sites.
     
  8. angelwatt Moderator emeritus

    angelwatt

    Joined:
    Aug 16, 2005
    Location:
    USA
    #9
    I'll tell you my settings for what it's worth. From System Preferences > Security > Firewall (tab) > Select Set access for specific services and applications. Then you can use the plus button toward the bottom to go and select the program you want to give permissions to and make sure it's set to allow incoming connections. You can probably also set the firewall to Allow all incoming connections, but I like to set my security a little stronger.

    The Sharing preferences shouldn't make any difference and the Network settings shouldn't matter if your Internet is working. The only other advice I can give is to troubleshoot. Mac has an app called Console (/Applications/Utilities/) and that follows a lot going on. Open it up then open your FTP program and try to connect. Once you get your error check Console and see what type of messages are popping up in there. You won't necessarily see anything of interest, but if there seems to be some relevant information you can't make heads or tails of copy and paste it here and maybe one of us will have a clue.
     
  9. camig macrumors newbie

    Joined:
    Nov 11, 2008
    Location:
    Armonk, NY
    #10
    MojoWill has it right. I do a lot of ftp work. This error is almost always because you need to be in passive mode. There's usually a check box that you can set.
     
  10. kevin08 thread starter macrumors newbie

    Joined:
    Nov 10, 2008
    #11
    still have problems

    this morning tried to upload a file to website server and it worked, next time tried upload in minutes it wouldn't upload . got this reply.
    fetch could not put photo1.jpg because FTP server has shut down. Try again contact server admin. connection couldn't be accepted software caused system abort.
    I have tried two other ftp programs same result
    cyberduck and fireftp

    I get connected to server as i can see the files there .
    someone has suggested that it is to with settings but have tried everything and still nothing. help would be appreciated
    thanks
    Kevin08
     
  11. ChicoWeb macrumors 65816

    ChicoWeb

    Joined:
    Aug 16, 2004
    Location:
    California
    #12
    Sounds like your server, I would contact your server admin.
     
  12. kevin08 thread starter macrumors newbie

    Joined:
    Nov 10, 2008
    #13
    solution

    It was settings on broadband router, still set to Optus after i changed isp company.
     

Share This Page